summaryrefslogtreecommitdiff
path: root/dev-libs/mimalloc/mimalloc-2.0.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/mimalloc/mimalloc-2.0.5-r1.ebuild')
-rw-r--r--dev-libs/mimalloc/mimalloc-2.0.5-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/mimalloc/mimalloc-2.0.5-r1.ebuild b/dev-libs/mimalloc/mimalloc-2.0.5-r1.ebuild
new file mode 100644
index 000000000000..0e19c310b3ee
--- /dev/null
+++ b/dev-libs/mimalloc/mimalloc-2.0.5-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="A compact general purpose allocator with excellent performance"
+HOMEPAGE="https://github.com/microsoft/mimalloc"
+SRC_URI="https://github.com/microsoft/mimalloc/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/2"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ # TODO: build hardened variant?
+ #-DMI_SECURE=$(usex hardened)
+
+ -DMI_INSTALL_TOPLEVEL=ON
+ -DMI_BUILD_TESTS=$(usex test)
+ )
+
+ cmake-multilib_src_configure
+}
+
+src_install() {
+ cmake-multilib_src_install
+
+ rm "${ED}/usr/$(get_libdir)/mimalloc.o" || die
+
+ find "${ED}" -name '*.a' -delete || die
+}