summaryrefslogtreecommitdiff
path: root/dev-libs/mimalloc/mimalloc-1.7.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/mimalloc/mimalloc-1.7.2.ebuild')
-rw-r--r--dev-libs/mimalloc/mimalloc-1.7.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/mimalloc/mimalloc-1.7.2.ebuild b/dev-libs/mimalloc/mimalloc-1.7.2.ebuild
new file mode 100644
index 000000000000..33efb631d03b
--- /dev/null
+++ b/dev-libs/mimalloc/mimalloc-1.7.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="mimalloc is a compact general purpose allocator with excellent performance"
+HOMEPAGE="https://github.com/microsoft/mimalloc"
+SRC_URI="https://github.com/microsoft/mimalloc/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/1"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7.2-GNUInstallDirs.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ # TODO: build hardened variant?
+ #-DMI_SECURE=$(usex hardened)
+
+ -DMI_INSTALL_TOPLEVEL=ON
+ -DMI_BUILD_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}