summaryrefslogtreecommitdiff
path: root/dev-libs/metee/metee-3.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/metee/metee-3.1.0.ebuild')
-rw-r--r--dev-libs/metee/metee-3.1.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/metee/metee-3.1.0.ebuild b/dev-libs/metee/metee-3.1.0.ebuild
new file mode 100644
index 000000000000..713c3b7a8cfa
--- /dev/null
+++ b/dev-libs/metee/metee-3.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Cross-platform access library for Intel CSME HECI interface"
+HOMEPAGE="https://github.com/intel/compute-runtime"
+SRC_URI="https://github.com/intel/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+BDEPEND="doc? ( app-doc/doxygen )"
+
+PATCHES=( "${FILESDIR}/${PN}-3.1.0-make-docs-optional.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DOCS="$(usex doc)"
+ -DBUILD_SAMPLES="NO"
+ -DBUILD_SHARED_LIBS="YES"
+ -DBUILD_TEST="NO"
+ -DCONSOLE_OUTPUT="NO"
+ )
+
+ cmake_src_configure
+}