summaryrefslogtreecommitdiff
path: root/dev-libs/libxslt/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libxslt/files')
-rw-r--r--dev-libs/libxslt/files/1.1.30-unbreak-xslt-config.patch37
-rw-r--r--dev-libs/libxslt/files/1.1.32-simplify-python.patch250
-rw-r--r--dev-libs/libxslt/files/libxslt-1.1.28-disable-static-modules.patch33
-rw-r--r--dev-libs/libxslt/files/libxslt-1.1.30-glibc226.patch32
-rw-r--r--dev-libs/libxslt/files/libxslt-1.1.30-simplify-python.patch250
-rw-r--r--dev-libs/libxslt/files/libxslt.m4-libxslt-1.1.26.patch38
6 files changed, 640 insertions, 0 deletions
diff --git a/dev-libs/libxslt/files/1.1.30-unbreak-xslt-config.patch b/dev-libs/libxslt/files/1.1.30-unbreak-xslt-config.patch
new file mode 100644
index 000000000000..6e367f976916
--- /dev/null
+++ b/dev-libs/libxslt/files/1.1.30-unbreak-xslt-config.patch
@@ -0,0 +1,37 @@
+From 9608d20739b36087f0e6865cc924769d3b286188 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Tue, 12 Sep 2017 23:44:35 +0200
+Subject: [PATCH] Move XML_CONFIG assignment to unbreak xslt-config
+
+Bug: https://bugs.gentoo.org/630784
+---
+ configure.in | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index e6f649cd..49e6b6cf 100644
+--- a/configure.in
++++ b/configure.in
+@@ -518,9 +518,6 @@ else
+ LIBXML_MANUAL_SEARCH=yes
+ fi
+
+-if test "x$LIBXML_MANUAL_SEARCH" != "xno"
+-then
+-
+ dnl
+ dnl where is xml2-config
+ dnl
+@@ -534,6 +531,9 @@ else
+ AC_PATH_TOOL([XML_CONFIG], [xml2-config], [false])
+ fi
+
++if test "x$LIBXML_MANUAL_SEARCH" != "xno"
++then
++
+ dnl
+ dnl imported from libxml2, c.f. #77827
+ dnl
+--
+2.14.1
+
diff --git a/dev-libs/libxslt/files/1.1.32-simplify-python.patch b/dev-libs/libxslt/files/1.1.32-simplify-python.patch
new file mode 100644
index 000000000000..d5a4401afd61
--- /dev/null
+++ b/dev-libs/libxslt/files/1.1.32-simplify-python.patch
@@ -0,0 +1,250 @@
+From aa0f7a8d59a9bbd646203d3f14e39e217961f725 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Wed, 11 Nov 2015 17:49:07 +0100
+Subject: [PATCH] Simplify python setup in autoconf
+
+AM_PATH_PYTHON does most of the job without using pkg-config as expected
+from the rest of the autoconf script.
+---
+ Makefile.am | 14 +++++--
+ configure.ac | 119 ++++++++++++++---------------------------------------
+ python/Makefile.am | 28 ++++---------
+ 3 files changed, 49 insertions(+), 112 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index ff10f574..65decb3c 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -2,9 +2,13 @@ SUBDIRS = \
+ libxslt \
+ libexslt \
+ xsltproc \
+- doc \
+- $(PYTHON_SUBDIR) \
+- tests
++ doc
++
++if WITH_PYTHON
++SUBDIRS += python
++endif
++
++SUBDIRS += tests
+
+ DIST_SUBDIRS = libxslt libexslt xsltproc python doc tests
+
+@@ -51,7 +55,9 @@ tests: dummy
+ @echo '## Running the regression test suite'
+ @(cd tests ; $(MAKE) -s tests)
+ @(cd xsltproc ; $(MAKE) -s tests)
+- @(if [ "$(PYTHON_SUBDIR)" != "" ] ; then cd python ; $(MAKE) -s tests ; fi)
++if WITH_PYTHON
++ @(cd python ; $(MAKE) -s tests)
++endif
+
+ valgrind:
+ @echo '## Running the regression tests under Valgrind'
+diff --git a/configure.ac b/configure.ac
+index d6aa3664..0a538944 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -293,90 +293,37 @@ dnl
+ dnl check for python
+ dnl
+
+-PYTHON_VERSION=
+-PYTHON_INCLUDES=
+-PYTHON_SITE_PACKAGES=
+-pythondir=
+-AC_ARG_WITH(python, [ --with-python[=DIR] Build Python bindings if found])
+-if test "$with_python" != "no" ; then
+- if test -x "$with_python/bin/python"
+- then
+- echo Found python in $with_python/bin/python
+- PYTHON="$with_python/bin/python"
+- else
+- if test -x "$with_python"
+- then
+- echo Found python in $with_python
+- PYTHON="$with_python"
+- else
+- if test -x "$PYTHON"
+- then
+- echo Found python in environment PYTHON=$PYTHON
+- with_python=`$PYTHON -c "import sys; print sys.exec_prefix"`
+- else
+- AC_PATH_PROG(PYTHON, python python2.4 python2.3 python2.2 python2.1 python2.0 python1.6 python1.5)
+- fi
+- fi
+- fi
+- if test "$PYTHON" != ""
+- then
+- echo "PYTHON is pointing at $PYTHON"
+- PYTHON_VERSION=`$PYTHON -c "import sys; print sys.version[[0:3]]"`
+- echo Found Python version $PYTHON_VERSION
+- LIBXML2_PYTHON=`$PYTHON -c "try : import libxml2 ; print 1
+-except: print 0"`
+- if test "$LIBXML2_PYTHON" = "1"
+- then
+- echo Found libxml2-python module
+- else
+- echo Warning: Missing libxml2-python
+- fi
+- fi
+- if test "$PYTHON_VERSION" != ""
+- then
+- if test -r $with_python/include/python$PYTHON_VERSION/Python.h -a \
+- -d $with_python/lib/python$PYTHON_VERSION/site-packages
+- then
+- PYTHON_INCLUDES=$with_python/include/python$PYTHON_VERSION
+- PYTHON_SITE_PACKAGES='$(libdir)/python$(PYTHON_VERSION)/site-packages'
+- else
+- if test -r $prefix/include/python$PYTHON_VERSION/Python.h
+- then
+- PYTHON_INCLUDES=$prefix/include/python$PYTHON_VERSION
+- PYTHON_SITE_PACKAGES='$(libdir)/python$(PYTHON_VERSION)/site-packages'
+- else
+- if test -r /usr/include/python$PYTHON_VERSION/Python.h
+- then
+- PYTHON_INCLUDES=/usr/include/python$PYTHON_VERSION
+- PYTHON_SITE_PACKAGES='$(libdir)/python$(PYTHON_VERSION)/site-packages'
+- else
+- echo could not find python$PYTHON_VERSION/Python.h
+- fi
+- fi
+- if test ! -d "$PYTHON_SITE_PACKAGES"
+- then
+- PYTHON_SITE_PACKAGES=`$PYTHON -c "from distutils import sysconfig; print sysconfig.get_python_lib()"`
+- fi
+- fi
+- PYTHON_LIBS=`python$PYTHON_VERSION-config --libs`
+- fi
+- if test "$with_python" != ""
+- then
+- pythondir='$(PYTHON_SITE_PACKAGES)'
+- else
+- pythondir='$(libdir)/python$(PYTHON_VERSION)/site-packages'
+- fi
+-fi
+-AM_CONDITIONAL(WITH_PYTHON, test "$PYTHON_INCLUDES" != "")
+-if test "$PYTHON_INCLUDES" != ""
+-then
+- PYTHON_SUBDIR=python
+-else
+- PYTHON_SUBDIR=
+-fi
+-AC_SUBST(pythondir)
+-AC_SUBST(PYTHON_SUBDIR)
+-AC_SUBST(PYTHON_LIBS)
++AC_ARG_WITH([python],
++ AS_HELP_STRING([--with-python], [Build Python bindings if found])
++)
++
++AS_IF([test "$with_python" = "yes"],
++ [AM_PATH_PYTHON
++ AC_PATH_TOOL([PYTHON_CONFIG], [python$PYTHON_VERSION-config], [no])
++ AS_IF([test "$PYTHON_CONFIG" = "no"],
++ [AC_PATH_TOOL([PYTHON_CONFIG], [python-config], [no])])
++ AS_IF([test "$PYTHON_CONFIG" != "no"],
++ [PYTHON_CFLAGS=`$PYTHON_CONFIG --cflags`
++ PYTHON_LDFLAGS=`$PYTHON_CONFIG --ldflags`
++ PYTHON_LIBS=`$PYTHON_CONFIG --libs`],
++ [AC_MSG_ERROR([Missing python development files.])])
++ AC_MSG_CHECKING([libxml2 module in $PYTHON])
++ LIBXML2_PYTHON=`$PYTHON -c "import sys;
++try:
++ import libxml2
++ sys.stdout.write('1')
++except:
++ sys.stdout.write('0')"`
++ AS_IF([test "$LIBXML2_PYTHON" = "1"],
++ [AC_MSG_RESULT([yes])],
++ [AC_MSG_RESULT([no])
++ AC_MSG_WARN([libxml2 python module not found, expect runtime errors])])
++ ])
++
++AM_CONDITIONAL([WITH_PYTHON], [test "$with_python" = "yes"])
++AC_SUBST([PYTHON_CFLAGS])
++AC_SUBST([PYTHON_LDFLAGS])
++AC_SUBST([PYTHON_LIBS])
+
+ AC_ARG_WITH(crypto, [ --with-crypto Add crypto support to exslt (on)])
+ WITH_CRYPTO=0
+@@ -678,10 +625,6 @@ AC_SUBST(PYTHONSODV)
+ AC_SUBST(XML_CONFIG)
+ AC_SUBST(LIBXML_LIBS)
+ AC_SUBST(LIBXML_CFLAGS)
+-AC_SUBST(PYTHON)
+-AC_SUBST(PYTHON_VERSION)
+-AC_SUBST(PYTHON_INCLUDES)
+-AC_SUBST(PYTHON_SITE_PACKAGES)
+
+ XSLT_LIBDIR='-L${libdir}'
+ XSLT_INCLUDEDIR='-I${includedir}'
+diff --git a/python/Makefile.am b/python/Makefile.am
+index fa58b78f..3a5ecd6a 100644
+--- a/python/Makefile.am
++++ b/python/Makefile.am
+@@ -5,9 +5,9 @@ SUBDIRS= . tests
+
+ AM_CFLAGS = $(LIBXML_CFLAGS)
+
+-DOCS_DIR = $(datadir)/doc/libxslt-python-$(LIBXSLT_VERSION)
++docsdir = $(datadir)/doc/libxslt-python-$(LIBXSLT_VERSION)
+ # libxsltclass.txt is generated
+-DOCS = TODO
++dist_docs_DATA = TODO
+
+ EXTRA_DIST = \
+ libxslt.c \
+@@ -16,10 +16,7 @@ EXTRA_DIST = \
+ libxml_wrap.h \
+ libxslt_wrap.h \
+ libxsl.py \
+- libxslt-python-api.xml \
+- $(DOCS)
+-
+-libxsltmod_la_LDFLAGS = $(WIN32_EXTRA_LDFLAGS) -module -avoid-version
++ libxslt-python-api.xml
+
+ if WITH_PYTHON
+ mylibs = \
+@@ -28,31 +25,22 @@ mylibs = \
+
+ all-local: libxslt.py
+
+-python_LTLIBRARIES = libxsltmod.la
++python_PYTHON = libxslt.py
++pyexec_LTLIBRARIES = libxsltmod.la
+
+ libxsltmod_la_CPPFLAGS = \
+- -I$(PYTHON_INCLUDES) \
+ -I$(top_srcdir)/libxslt \
+ -I$(top_srcdir) \
+- -I../libexslt
++ -I$(top_srcdir)/libexslt \
++ $(PYTHON_CFLAGS)
+ libxsltmod_la_SOURCES = libxslt.c types.c
+ nodist_libxsltmod_la_SOURCES = libxslt-py.c
+ libxsltmod_la_LIBADD = $(mylibs) $(PYTHON_LIBS)
++libxsltmod_la_LDFLAGS = $(WIN32_EXTRA_LDFLAGS) $(PYTHON_LDFLAGS) -module -avoid-version
+
+ libxslt.py: $(srcdir)/libxsl.py libxsltclass.py
+ cat $(srcdir)/libxsl.py libxsltclass.py > $@
+
+-install-data-local:
+- $(MKDIR_P) $(DESTDIR)$(pythondir)
+- $(INSTALL) -m 0644 libxslt.py $(DESTDIR)$(pythondir)
+- $(MKDIR_P) $(DESTDIR)$(DOCS_DIR)
+- @(for doc in $(DOCS) ; \
+- do $(INSTALL) -m 0644 $(srcdir)/$$doc $(DESTDIR)$(DOCS_DIR) ; done)
+-
+-uninstall-local:
+- rm -f $(DESTDIR)$(pythondir)/libxslt.py
+- rm -rf $(DESTDIR)$(DOCS_DIR)
+-
+ GENERATE = generator.py
+ API_DESC = $(top_srcdir)/doc/libxslt-api.xml $(srcdir)/libxslt-python-api.xml
+ GENERATED= libxsltclass.py \
+--
+2.14.1
+
diff --git a/dev-libs/libxslt/files/libxslt-1.1.28-disable-static-modules.patch b/dev-libs/libxslt/files/libxslt-1.1.28-disable-static-modules.patch
new file mode 100644
index 000000000000..b30a08406d31
--- /dev/null
+++ b/dev-libs/libxslt/files/libxslt-1.1.28-disable-static-modules.patch
@@ -0,0 +1,33 @@
+From 06c9dba42097b06a18c81bb54a8da8b2bfaf991d Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Wed, 11 Nov 2015 20:01:14 +0100
+Subject: [PATCH 3/3] Disable static module for python module
+
+---
+ python/Makefile.am | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/python/Makefile.am b/python/Makefile.am
+index cc13c62..62afd1b 100644
+--- a/python/Makefile.am
++++ b/python/Makefile.am
+@@ -27,6 +27,7 @@ python_PYTHON = libxslt.py
+ pyexec_LTLIBRARIES = libxsltmod.la
+
+ libxsltmod_la_CPPFLAGS = \
++ -shared \
+ -I$(top_srcdir)/libxslt \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/libexslt \
+@@ -34,7 +35,7 @@ libxsltmod_la_CPPFLAGS = \
+ libxsltmod_la_SOURCES = libxslt.c types.c
+ nodist_libxsltmod_la_SOURCES = libxslt-py.c
+ libxsltmod_la_LIBADD = $(mylibs) $(PYTHON_LIBS)
+-libxsltmod_la_LDFLAGS = $(WIN32_EXTRA_LDFLAGS) $(PYTHON_LDFLAGS) -module -avoid-version
++libxsltmod_la_LDFLAGS = $(WIN32_EXTRA_LDFLAGS) $(PYTHON_LDFLAGS) -module -avoid-version -shared
+
+ libxslt.py: $(srcdir)/libxsl.py libxsltclass.py
+ cat $(srcdir)/libxsl.py libxsltclass.py > $@
+--
+2.6.3
+
diff --git a/dev-libs/libxslt/files/libxslt-1.1.30-glibc226.patch b/dev-libs/libxslt/files/libxslt-1.1.30-glibc226.patch
new file mode 100644
index 000000000000..e1e97229d60f
--- /dev/null
+++ b/dev-libs/libxslt/files/libxslt-1.1.30-glibc226.patch
@@ -0,0 +1,32 @@
+diff --git a/configure.in b/configure.in
+index d6aa366..20aafb8 100644
+--- a/configure.in
++++ b/configure.in
+@@ -165,11 +165,11 @@ XSLT_LOCALE_XLOCALE=0
+ XSLT_LOCALE_WINAPI=0
+
+ AC_CHECK_HEADERS([locale.h xlocale.h])
+-if test $ac_cv_header_xlocale_h = yes; then
++if test $ac_cv_header_locale_h = yes; then
+ dnl
+ dnl Check for generic locale_t declaration
+ dnl
+-AC_MSG_CHECKING([if xlocale program link])
++AC_MSG_CHECKING([if locale program link])
+ AC_LINK_IFELSE([AC_LANG_PROGRAM([[
+ #ifdef HAVE_LOCALE_H
+ #include <locale.h>
+diff --git a/libxslt/xsltlocale.h b/libxslt/xsltlocale.h
+index 8a9ca15..2f64424 100644
+--- a/libxslt/xsltlocale.h
++++ b/libxslt/xsltlocale.h
+@@ -17,7 +17,9 @@
+ #ifdef XSLT_LOCALE_XLOCALE
+
+ #include <locale.h>
++#if defined(__GLIBC__) && __GLIBC__ == 2 && __GLIBC_MINOR__ < 26
+ #include <xlocale.h>
++#endif
+
+ #ifdef __GLIBC__
+ /*locale_t is defined only if _GNU_SOURCE is defined*/
diff --git a/dev-libs/libxslt/files/libxslt-1.1.30-simplify-python.patch b/dev-libs/libxslt/files/libxslt-1.1.30-simplify-python.patch
new file mode 100644
index 000000000000..dac84fa66308
--- /dev/null
+++ b/dev-libs/libxslt/files/libxslt-1.1.30-simplify-python.patch
@@ -0,0 +1,250 @@
+From aa0f7a8d59a9bbd646203d3f14e39e217961f725 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Wed, 11 Nov 2015 17:49:07 +0100
+Subject: [PATCH] Simplify python setup in autoconf
+
+AM_PATH_PYTHON does most of the job without using pkg-config as expected
+from the rest of the autoconf script.
+---
+ Makefile.am | 14 +++++--
+ configure.in | 119 ++++++++++++++---------------------------------------
+ python/Makefile.am | 28 ++++---------
+ 3 files changed, 49 insertions(+), 112 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index ff10f574..65decb3c 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -2,9 +2,13 @@ SUBDIRS = \
+ libxslt \
+ libexslt \
+ xsltproc \
+- doc \
+- $(PYTHON_SUBDIR) \
+- tests
++ doc
++
++if WITH_PYTHON
++SUBDIRS += python
++endif
++
++SUBDIRS += tests
+
+ DIST_SUBDIRS = libxslt libexslt xsltproc python doc tests
+
+@@ -51,7 +55,9 @@ tests: dummy
+ @echo '## Running the regression test suite'
+ @(cd tests ; $(MAKE) -s tests)
+ @(cd xsltproc ; $(MAKE) -s tests)
+- @(if [ "$(PYTHON_SUBDIR)" != "" ] ; then cd python ; $(MAKE) -s tests ; fi)
++if WITH_PYTHON
++ @(cd python ; $(MAKE) -s tests)
++endif
+
+ valgrind:
+ @echo '## Running the regression tests under Valgrind'
+diff --git a/configure.in b/configure.in
+index d6aa3664..0a538944 100644
+--- a/configure.in
++++ b/configure.in
+@@ -293,90 +293,37 @@ dnl
+ dnl check for python
+ dnl
+
+-PYTHON_VERSION=
+-PYTHON_INCLUDES=
+-PYTHON_SITE_PACKAGES=
+-pythondir=
+-AC_ARG_WITH(python, [ --with-python[=DIR] Build Python bindings if found])
+-if test "$with_python" != "no" ; then
+- if test -x "$with_python/bin/python"
+- then
+- echo Found python in $with_python/bin/python
+- PYTHON="$with_python/bin/python"
+- else
+- if test -x "$with_python"
+- then
+- echo Found python in $with_python
+- PYTHON="$with_python"
+- else
+- if test -x "$PYTHON"
+- then
+- echo Found python in environment PYTHON=$PYTHON
+- with_python=`$PYTHON -c "import sys; print sys.exec_prefix"`
+- else
+- AC_PATH_PROG(PYTHON, python python2.4 python2.3 python2.2 python2.1 python2.0 python1.6 python1.5)
+- fi
+- fi
+- fi
+- if test "$PYTHON" != ""
+- then
+- echo "PYTHON is pointing at $PYTHON"
+- PYTHON_VERSION=`$PYTHON -c "import sys; print sys.version[[0:3]]"`
+- echo Found Python version $PYTHON_VERSION
+- LIBXML2_PYTHON=`$PYTHON -c "try : import libxml2 ; print 1
+-except: print 0"`
+- if test "$LIBXML2_PYTHON" = "1"
+- then
+- echo Found libxml2-python module
+- else
+- echo Warning: Missing libxml2-python
+- fi
+- fi
+- if test "$PYTHON_VERSION" != ""
+- then
+- if test -r $with_python/include/python$PYTHON_VERSION/Python.h -a \
+- -d $with_python/lib/python$PYTHON_VERSION/site-packages
+- then
+- PYTHON_INCLUDES=$with_python/include/python$PYTHON_VERSION
+- PYTHON_SITE_PACKAGES='$(libdir)/python$(PYTHON_VERSION)/site-packages'
+- else
+- if test -r $prefix/include/python$PYTHON_VERSION/Python.h
+- then
+- PYTHON_INCLUDES=$prefix/include/python$PYTHON_VERSION
+- PYTHON_SITE_PACKAGES='$(libdir)/python$(PYTHON_VERSION)/site-packages'
+- else
+- if test -r /usr/include/python$PYTHON_VERSION/Python.h
+- then
+- PYTHON_INCLUDES=/usr/include/python$PYTHON_VERSION
+- PYTHON_SITE_PACKAGES='$(libdir)/python$(PYTHON_VERSION)/site-packages'
+- else
+- echo could not find python$PYTHON_VERSION/Python.h
+- fi
+- fi
+- if test ! -d "$PYTHON_SITE_PACKAGES"
+- then
+- PYTHON_SITE_PACKAGES=`$PYTHON -c "from distutils import sysconfig; print sysconfig.get_python_lib()"`
+- fi
+- fi
+- PYTHON_LIBS=`python$PYTHON_VERSION-config --libs`
+- fi
+- if test "$with_python" != ""
+- then
+- pythondir='$(PYTHON_SITE_PACKAGES)'
+- else
+- pythondir='$(libdir)/python$(PYTHON_VERSION)/site-packages'
+- fi
+-fi
+-AM_CONDITIONAL(WITH_PYTHON, test "$PYTHON_INCLUDES" != "")
+-if test "$PYTHON_INCLUDES" != ""
+-then
+- PYTHON_SUBDIR=python
+-else
+- PYTHON_SUBDIR=
+-fi
+-AC_SUBST(pythondir)
+-AC_SUBST(PYTHON_SUBDIR)
+-AC_SUBST(PYTHON_LIBS)
++AC_ARG_WITH([python],
++ AS_HELP_STRING([--with-python], [Build Python bindings if found])
++)
++
++AS_IF([test "$with_python" = "yes"],
++ [AM_PATH_PYTHON
++ AC_PATH_TOOL([PYTHON_CONFIG], [python$PYTHON_VERSION-config], [no])
++ AS_IF([test "$PYTHON_CONFIG" = "no"],
++ [AC_PATH_TOOL([PYTHON_CONFIG], [python-config], [no])])
++ AS_IF([test "$PYTHON_CONFIG" != "no"],
++ [PYTHON_CFLAGS=`$PYTHON_CONFIG --cflags`
++ PYTHON_LDFLAGS=`$PYTHON_CONFIG --ldflags`
++ PYTHON_LIBS=`$PYTHON_CONFIG --libs`],
++ [AC_MSG_ERROR([Missing python development files.])])
++ AC_MSG_CHECKING([libxml2 module in $PYTHON])
++ LIBXML2_PYTHON=`$PYTHON -c "import sys;
++try:
++ import libxml2
++ sys.stdout.write('1')
++except:
++ sys.stdout.write('0')"`
++ AS_IF([test "$LIBXML2_PYTHON" = "1"],
++ [AC_MSG_RESULT([yes])],
++ [AC_MSG_RESULT([no])
++ AC_MSG_WARN([libxml2 python module not found, expect runtime errors])])
++ ])
++
++AM_CONDITIONAL([WITH_PYTHON], [test "$with_python" = "yes"])
++AC_SUBST([PYTHON_CFLAGS])
++AC_SUBST([PYTHON_LDFLAGS])
++AC_SUBST([PYTHON_LIBS])
+
+ AC_ARG_WITH(crypto, [ --with-crypto Add crypto support to exslt (on)])
+ WITH_CRYPTO=0
+@@ -678,10 +625,6 @@ AC_SUBST(PYTHONSODV)
+ AC_SUBST(XML_CONFIG)
+ AC_SUBST(LIBXML_LIBS)
+ AC_SUBST(LIBXML_CFLAGS)
+-AC_SUBST(PYTHON)
+-AC_SUBST(PYTHON_VERSION)
+-AC_SUBST(PYTHON_INCLUDES)
+-AC_SUBST(PYTHON_SITE_PACKAGES)
+
+ XSLT_LIBDIR='-L${libdir}'
+ XSLT_INCLUDEDIR='-I${includedir}'
+diff --git a/python/Makefile.am b/python/Makefile.am
+index fa58b78f..3a5ecd6a 100644
+--- a/python/Makefile.am
++++ b/python/Makefile.am
+@@ -5,9 +5,9 @@ SUBDIRS= . tests
+
+ AM_CFLAGS = $(LIBXML_CFLAGS)
+
+-DOCS_DIR = $(datadir)/doc/libxslt-python-$(LIBXSLT_VERSION)
++docsdir = $(datadir)/doc/libxslt-python-$(LIBXSLT_VERSION)
+ # libxsltclass.txt is generated
+-DOCS = TODO
++dist_docs_DATA = TODO
+
+ EXTRA_DIST = \
+ libxslt.c \
+@@ -16,10 +16,7 @@ EXTRA_DIST = \
+ libxml_wrap.h \
+ libxslt_wrap.h \
+ libxsl.py \
+- libxslt-python-api.xml \
+- $(DOCS)
+-
+-libxsltmod_la_LDFLAGS = $(WIN32_EXTRA_LDFLAGS) -module -avoid-version
++ libxslt-python-api.xml
+
+ if WITH_PYTHON
+ mylibs = \
+@@ -28,31 +25,22 @@ mylibs = \
+
+ all-local: libxslt.py
+
+-python_LTLIBRARIES = libxsltmod.la
++python_PYTHON = libxslt.py
++pyexec_LTLIBRARIES = libxsltmod.la
+
+ libxsltmod_la_CPPFLAGS = \
+- -I$(PYTHON_INCLUDES) \
+ -I$(top_srcdir)/libxslt \
+ -I$(top_srcdir) \
+- -I../libexslt
++ -I$(top_srcdir)/libexslt \
++ $(PYTHON_CFLAGS)
+ libxsltmod_la_SOURCES = libxslt.c types.c
+ nodist_libxsltmod_la_SOURCES = libxslt-py.c
+ libxsltmod_la_LIBADD = $(mylibs) $(PYTHON_LIBS)
++libxsltmod_la_LDFLAGS = $(WIN32_EXTRA_LDFLAGS) $(PYTHON_LDFLAGS) -module -avoid-version
+
+ libxslt.py: $(srcdir)/libxsl.py libxsltclass.py
+ cat $(srcdir)/libxsl.py libxsltclass.py > $@
+
+-install-data-local:
+- $(MKDIR_P) $(DESTDIR)$(pythondir)
+- $(INSTALL) -m 0644 libxslt.py $(DESTDIR)$(pythondir)
+- $(MKDIR_P) $(DESTDIR)$(DOCS_DIR)
+- @(for doc in $(DOCS) ; \
+- do $(INSTALL) -m 0644 $(srcdir)/$$doc $(DESTDIR)$(DOCS_DIR) ; done)
+-
+-uninstall-local:
+- rm -f $(DESTDIR)$(pythondir)/libxslt.py
+- rm -rf $(DESTDIR)$(DOCS_DIR)
+-
+ GENERATE = generator.py
+ API_DESC = $(top_srcdir)/doc/libxslt-api.xml $(srcdir)/libxslt-python-api.xml
+ GENERATED= libxsltclass.py \
+--
+2.14.1
+
diff --git a/dev-libs/libxslt/files/libxslt.m4-libxslt-1.1.26.patch b/dev-libs/libxslt/files/libxslt.m4-libxslt-1.1.26.patch
new file mode 100644
index 000000000000..d6aaae4e9df0
--- /dev/null
+++ b/dev-libs/libxslt/files/libxslt.m4-libxslt-1.1.26.patch
@@ -0,0 +1,38 @@
+diff -ur libxslt-1.1.26.orig/libxslt.m4 libxslt-1.1.26/libxslt.m4
+--- libxslt-1.1.26.orig/libxslt.m4 2009-05-12 09:29:34.000000000 +0300
++++ libxslt-1.1.26/libxslt.m4 2009-10-07 17:03:04.000000000 +0300
+@@ -52,8 +52,10 @@
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
+ if test "x$enable_xslttest" = "xyes" ; then
+ ac_save_CFLAGS="$CFLAGS"
++ ac_save_CXXFLAGS="$CXXFLAGS"
+ ac_save_LIBS="$LIBS"
+ CFLAGS="$CFLAGS $XSLT_CFLAGS"
++ CXXFLAGS="$CXXFLAGS $XSLT_CFLAGS"
+ LIBS="$XSLT_LIBS $LIBS"
+ dnl
+ dnl Now check if the installed libxslt is sufficiently new.
+@@ -138,6 +140,7 @@
+ }
+ ],, no_xslt=yes,[echo $ac_n "cross compiling; assumed OK... $ac_c"])
+ CFLAGS="$ac_save_CFLAGS"
++ CXXFLAGS="$ac_save_CXXFLAGS"
+ LIBS="$ac_save_LIBS"
+ fi
+ fi
+@@ -158,6 +161,7 @@
+ else
+ echo "*** Could not run libxslt test program, checking why..."
+ CFLAGS="$CFLAGS $XSLT_CFLAGS"
++ CXXFLAGS="$CXXFLAGS $XSLT_CFLAGS"
+ LIBS="$LIBS $XSLT_LIBS"
+ AC_TRY_LINK([
+ #include <libxslt/xslt.h>
+@@ -177,6 +181,7 @@
+ echo "*** or that you have moved LIBXSLT since it was installed. In the latter case, you"
+ echo "*** may want to edit the xslt-config script: $XSLT_CONFIG" ])
+ CFLAGS="$ac_save_CFLAGS"
++ CXXFLAGS="$ac_save_CXXFLAGS"
+ LIBS="$ac_save_LIBS"
+ fi
+ fi