summaryrefslogtreecommitdiff
path: root/dev-libs/libxmlb/libxmlb-0.1.15.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libxmlb/libxmlb-0.1.15.ebuild')
-rw-r--r--dev-libs/libxmlb/libxmlb-0.1.15.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-libs/libxmlb/libxmlb-0.1.15.ebuild b/dev-libs/libxmlb/libxmlb-0.1.15.ebuild
index 68409989938f..80a864311d25 100644
--- a/dev-libs/libxmlb/libxmlb-0.1.15.ebuild
+++ b/dev-libs/libxmlb/libxmlb-0.1.15.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit meson python-any-r1
@@ -31,11 +31,11 @@ DEPEND="
"
BDEPEND="
+ ${PYTHON_DEPS}
>=dev-util/meson-0.47.0
virtual/pkgconfig
introspection? (
$(python_gen_any_dep 'dev-python/setuptools[${PYTHON_USEDEP}]')
- ${PYTHON_DEPS}
)
"
@@ -44,7 +44,7 @@ python_check_deps() {
}
pkg_setup() {
- use introspection && python-any-r1_pkg_setup
+ python-any-r1_pkg_setup
}
src_configure() {