summaryrefslogtreecommitdiff
path: root/dev-libs/libxml2/libxml2-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libxml2/libxml2-9999.ebuild')
-rw-r--r--dev-libs/libxml2/libxml2-9999.ebuild51
1 files changed, 30 insertions, 21 deletions
diff --git a/dev-libs/libxml2/libxml2-9999.ebuild b/dev-libs/libxml2/libxml2-9999.ebuild
index 3ad0604b6f1e..847a7c331d40 100644
--- a/dev-libs/libxml2/libxml2-9999.ebuild
+++ b/dev-libs/libxml2/libxml2-9999.ebuild
@@ -7,7 +7,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="xml"
-inherit autotools flag-o-matic python-r1 multilib-minimal
+inherit flag-o-matic python-r1 multilib-minimal
XSTS_HOME="http://www.w3.org/XML/2004/xml-schema-test-suite"
XSTS_NAME_1="xmlschema2002-01-16"
@@ -20,10 +20,10 @@ DESCRIPTION="XML C parser and toolkit"
HOMEPAGE="http://www.xmlsoft.org/ https://gitlab.gnome.org/GNOME/libxml2"
if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/libxml2"
- inherit git-r3
+ inherit autotools git-r3
else
- inherit gnome.org
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ inherit gnome.org libtool
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
SRC_URI+="
@@ -40,18 +40,17 @@ IUSE="debug examples icu lzma +python readline static-libs test"
RESTRICT="!test? ( test )"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-BDEPEND="
- dev-util/gtk-doc-am
- virtual/pkgconfig
-"
-RDEPEND="
- >=sys-libs/zlib-1.2.8-r1:=[${MULTILIB_USEDEP}]
+RDEPEND=">=sys-libs/zlib-1.2.8-r1:=[${MULTILIB_USEDEP}]
icu? ( >=dev-libs/icu-51.2-r1:=[${MULTILIB_USEDEP}] )
lzma? ( >=app-arch/xz-utils-5.0.5-r1:=[${MULTILIB_USEDEP}] )
python? ( ${PYTHON_DEPS} )
- readline? ( sys-libs/readline:= )
-"
+ readline? ( sys-libs/readline:= )"
DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+if [[ ${PV} == 9999 ]] ; then
+ BDEPEND+=" dev-util/gtk-doc-am"
+fi
MULTILIB_CHOST_TOOLS=(
/usr/bin/xml2-config
@@ -59,6 +58,10 @@ MULTILIB_CHOST_TOOLS=(
DOCS=( NEWS README.md TODO TODO_SCHEMAS python/TODO )
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.9.8-out-of-tree-test.patch
+)
+
src_unpack() {
if [[ ${PV} == 9999 ]] ; then
git-r3_src_unpack
@@ -67,7 +70,11 @@ src_unpack() {
# ${A} isn't used to avoid unpacking of test tarballs into ${WORKDIR},
# as they are needed as tarballs in ${S}/xstc instead and not unpacked
- unpack ${tarname} ${PN}-${PATCHSET_VERSION}.tar.bz2
+ unpack ${tarname}
+
+ if [[ -n ${PATCHSET_VERSION} ]] ; then
+ unpack ${PN}-${PATCHSET_VERSION}.tar.bz2
+ fi
fi
cd "${S}" || die
@@ -84,22 +91,22 @@ src_unpack() {
src_prepare() {
default
- # Please do not remove, as else we get references to PORTAGE_TMPDIR
- # in /usr/lib/python?.?/site-packages/libxml2mod.la among things.
- # We now need to run eautoreconf at the end to prevent maintainer mode.
- #elibtoolize
- # Needed for https://gitlab.gnome.org/GNOME/libxml2/-/issues/338 too in 2.9.13
- eautoreconf
+ if [[ ${PV} == 9999 ]] ; then
+ eautoreconf
+ else
+ # Please do not remove, as else we get references to PORTAGE_TMPDIR
+ # in /usr/lib/python?.?/site-packages/libxml2mod.la among things.
+ elibtoolize
+ fi
}
multilib_src_configure() {
- # Filter seemingly problematic CFLAGS (#26320)
+ # Filter seemingly problematic CFLAGS (bug #26320)
filter-flags -fprefetch-loop-arrays -funroll-loops
# Notes:
# The meaning of the 'debug' USE flag does not apply to the --with-debug
# switch (enabling the libxml2 debug module). See bug #100898.
-
libxml2_configure() {
ECONF_SOURCE="${S}" econf \
--enable-ipv6 \
@@ -160,6 +167,8 @@ multilib_src_install_all() {
rm -rf "${ED}"/usr/share/doc/${PF}/python/examples || die
fi
+ rm -rf "${ED}"/usr/share/doc/${PN}-python-${PVR} || die
+
find "${ED}" -name '*.la' -delete || die
}