summaryrefslogtreecommitdiff
path: root/dev-libs/libxml2/libxml2-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libxml2/libxml2-9999.ebuild')
-rw-r--r--dev-libs/libxml2/libxml2-9999.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-libs/libxml2/libxml2-9999.ebuild b/dev-libs/libxml2/libxml2-9999.ebuild
index b7e202fefbb5..45757ffa2a9d 100644
--- a/dev-libs/libxml2/libxml2-9999.ebuild
+++ b/dev-libs/libxml2/libxml2-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=8
# Note: Please bump in sync with dev-libs/libxslt
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="xml(+)"
inherit flag-o-matic python-r1 multilib-minimal
@@ -101,6 +101,10 @@ multilib_src_configure() {
# Filter seemingly problematic CFLAGS (bug #26320)
filter-flags -fprefetch-loop-arrays -funroll-loops
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ append-libs iconv
+ fi
+
# Notes:
# The meaning of the 'debug' USE flag does not apply to the --with-debug
# switch (enabling the libxml2 debug module). See bug #100898.