summaryrefslogtreecommitdiff
path: root/dev-libs/libxdiff/libxdiff-0.23-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libxdiff/libxdiff-0.23-r2.ebuild')
-rw-r--r--dev-libs/libxdiff/libxdiff-0.23-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/libxdiff/libxdiff-0.23-r2.ebuild b/dev-libs/libxdiff/libxdiff-0.23-r2.ebuild
new file mode 100644
index 000000000000..829e75cccad9
--- /dev/null
+++ b/dev-libs/libxdiff/libxdiff-0.23-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Library for creating diff files"
+HOMEPAGE="http://www.xmailserver.org/xdiff-lib.html"
+SRC_URI="http://www.xmailserver.org/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ default
+ # test utils require static libs ...
+ sed 's/test//g' -i Makefile.am
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+ rm "${D}/usr/$(get_libdir)"/*.la
+}