summaryrefslogtreecommitdiff
path: root/dev-libs/libwbxml/libwbxml-0.11.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libwbxml/libwbxml-0.11.8.ebuild')
-rw-r--r--dev-libs/libwbxml/libwbxml-0.11.8.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/libwbxml/libwbxml-0.11.8.ebuild b/dev-libs/libwbxml/libwbxml-0.11.8.ebuild
new file mode 100644
index 000000000000..8a8e8ca6f73a
--- /dev/null
+++ b/dev-libs/libwbxml/libwbxml-0.11.8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Library and tools to parse, encode and handle WBXML documents"
+HOMEPAGE="https://github.com/libwbxml/libwbxml"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-libs/expat
+ virtual/libiconv"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check )"
+
+DOCS=( BUGS ChangeLog README References THANKS TODO )
+S=${WORKDIR}/${PN}-${P}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_INSTALL_DOC=OFF
+ -DENABLE_UNIT_TEST=$(usex test)
+ )
+
+ cmake_src_configure
+}