summaryrefslogtreecommitdiff
path: root/dev-libs/libvoikko/libvoikko-4.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libvoikko/libvoikko-4.2.ebuild')
-rw-r--r--dev-libs/libvoikko/libvoikko-4.2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-libs/libvoikko/libvoikko-4.2.ebuild b/dev-libs/libvoikko/libvoikko-4.2.ebuild
new file mode 100644
index 000000000000..7bdff963650d
--- /dev/null
+++ b/dev-libs/libvoikko/libvoikko-4.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5..7}} )
+
+inherit python-r1
+
+DESCRIPTION="Spell checking, hyphenation and morphological analysis tool for Finnish language"
+HOMEPAGE="https://voikko.puimula.org/"
+SRC_URI="https://www.puimula.org/voikko-sources/${PN}/${P}.tar.gz"
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+expvfst +hfst"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="test"
+
+DEPEND="${PYTHON_DEPS}
+ hfst? ( >=dev-util/hfstospell-0.5.0 )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myconf=(
+ --prefix=/usr
+ --with-dictionary-path=/usr/share/voikko
+ $(use_enable expvfst)
+ )
+
+ if ! use hfst ; then
+ myconf+=( --disable-hfst )
+ fi
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ python_setup
+ default
+
+ python_foreach_impl python_domodule python/libvoikko.py
+}