summaryrefslogtreecommitdiff
path: root/dev-libs/libuninum
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libuninum')
-rw-r--r--dev-libs/libuninum/Manifest2
-rw-r--r--dev-libs/libuninum/libuninum-2.7-r1.ebuild10
2 files changed, 11 insertions, 1 deletions
diff --git a/dev-libs/libuninum/Manifest b/dev-libs/libuninum/Manifest
index b9a9eb729360..5660e77e7fef 100644
--- a/dev-libs/libuninum/Manifest
+++ b/dev-libs/libuninum/Manifest
@@ -1,3 +1,3 @@
DIST libuninum-2.7.tar.bz2 276712 BLAKE2B 0894c632d7e9081f35d543895809bcc04fde6da674d4e6adc7cdc914f4bbb257a3e683b381e6496a08b65790731f73315d8263970265a351f40fe504f210c883 SHA512 4536a90b9f34fbabd3cc0560c1ff385063151bc381de51e6ca0253d2a42c2290b92329795b1a12ade305c3cb5757b02fe9d92817829977f50da2e34852936274
-EBUILD libuninum-2.7-r1.ebuild 547 BLAKE2B 12e74679be85c9f358fb88daeb3bd64b0aa70dca3379e08d48cdff5b4dc4a19dc0fcb18e2f289e2223b5327dcd890c0a6856f98bdeb4b5cbbc25806f52b269f3 SHA512 0c1868496446b94aa60538ec0efd0ace5d721399000ec3512a908f6224a7c05eafb26a6a28dbbbbb287cdbd5d5e43889e7cabdf2259ee7d17789faa4b168368c
+EBUILD libuninum-2.7-r1.ebuild 670 BLAKE2B 0351233edafd29e02f530f084aba4dae3cae7821c1803029d473807da7d68b216fc6aa5a2bfb9e2fd4968f34cfcb551c0267f5f1a71b76516c47d2cecd0d37b1 SHA512 e5e21872d1a39cd7b5bc44838c4dc995962258b947f57575a1aba9a07633e3a464fd6290fa7fa15c11564c1cb048ac6ef9b476e2607e78b1419f4e177eb545d1
MISC metadata.xml 688 BLAKE2B 186bacb0b23253d1dbbfcdf05e0611bf6c5c26cd68852b492dc65cd2f0f86ecb34f51965d32517b1354afacd04dec68899babd64424e27dceb34186d117cb27d SHA512 378145a6c5b69cae0a072cb28d1bbfa5a6fa3f708e450ae92bdd99e81ed862b9b8b290a13299ef928a1bcf06e1e6e61bf9dea51d5054007bd609932f394da5b4
diff --git a/dev-libs/libuninum/libuninum-2.7-r1.ebuild b/dev-libs/libuninum/libuninum-2.7-r1.ebuild
index 0307915cebf4..1a786ed1da32 100644
--- a/dev-libs/libuninum/libuninum-2.7-r1.ebuild
+++ b/dev-libs/libuninum/libuninum-2.7-r1.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit flag-o-matic
+
DESCRIPTION="A library for converting unicode strings to numbers and vice versa"
HOMEPAGE="https://billposer.org/Software/libuninum.html"
SRC_URI="https://billposer.org/Software/Downloads/${P}.tar.bz2"
@@ -11,6 +13,14 @@ KEYWORDS="amd64 x86"
LICENSE="GPL-2 GPL-2+ LGPL-2 LGPL-2.1"
SLOT="0"
+src_prepare() {
+ default
+
+ # LTO does not work.
+ # See https://bugs.gentoo.org/855956
+ filter-lto
+}
+
src_configure() {
local myeconfargs=(
--disable-static