summaryrefslogtreecommitdiff
path: root/dev-libs/libtomcrypt/libtomcrypt-1.18.2-r4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libtomcrypt/libtomcrypt-1.18.2-r4.ebuild')
-rw-r--r--dev-libs/libtomcrypt/libtomcrypt-1.18.2-r4.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-libs/libtomcrypt/libtomcrypt-1.18.2-r4.ebuild b/dev-libs/libtomcrypt/libtomcrypt-1.18.2-r4.ebuild
index da71154a8a6b..a42911b32ece 100644
--- a/dev-libs/libtomcrypt/libtomcrypt-1.18.2-r4.ebuild
+++ b/dev-libs/libtomcrypt/libtomcrypt-1.18.2-r4.ebuild
@@ -28,12 +28,15 @@ BDEPEND="
sys-devel/libtool
virtual/pkgconfig
"
-DEPEND="
+RDEPEND="
gmp? ( dev-libs/gmp:= )
libtommath? ( dev-libs/libtommath:= )
tomsfastmath? ( dev-libs/tomsfastmath:= )
"
-RDEPEND="${DEPEND}"
+DEPEND="
+ ${RDEPEND}
+ sys-devel/libtool
+"
PATCHES=(
"${FILESDIR}"/${P}-slibtool.patch
@@ -73,6 +76,9 @@ mymake() {
enabled_features+=( -DUSE_TFM=1 )
fi
+ # Fix cross-compiling, but allow manual overrides for slibtool, which works.
+ [[ -z ${LIBTOOL} ]] && declare -x LIBTOOL="${BASH} ${ESYSROOT}/usr/bin/libtool"
+
# IGNORE_SPEED=1 is needed to respect CFLAGS
EXTRALIBS="${extra_libs[*]}" emake \
CFLAGS="${CFLAGS} ${enabled_features[*]}" \