summaryrefslogtreecommitdiff
path: root/dev-libs/libstrl/libstrl-0.5.1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libstrl/libstrl-0.5.1-r2.ebuild')
-rw-r--r--dev-libs/libstrl/libstrl-0.5.1-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/libstrl/libstrl-0.5.1-r2.ebuild b/dev-libs/libstrl/libstrl-0.5.1-r2.ebuild
new file mode 100644
index 000000000000..13faa3a50256
--- /dev/null
+++ b/dev-libs/libstrl/libstrl-0.5.1-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Compat library for functions like strlcpy(), strlcat(), strnlen(), getline()"
+HOMEPAGE="http://ohnopub.net/~ohnobinki/libstrl/"
+SRC_URI="http://mirror.ohnopub.net/mirror/${P}.tar.bz2"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x64-macos"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ doc? ( app-doc/doxygen )
+ test? ( dev-libs/check )
+"
+
+src_configure() {
+ tc-export AR
+
+ econf \
+ $(use_with doc doxygen) \
+ $(use_with test check)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}