summaryrefslogtreecommitdiff
path: root/dev-libs/librevenge/librevenge-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/librevenge/librevenge-9999.ebuild')
-rw-r--r--dev-libs/librevenge/librevenge-9999.ebuild24
1 files changed, 9 insertions, 15 deletions
diff --git a/dev-libs/librevenge/librevenge-9999.ebuild b/dev-libs/librevenge/librevenge-9999.ebuild
index 0974dd13bd95..8c6dc01b3c64 100644
--- a/dev-libs/librevenge/librevenge-9999.ebuild
+++ b/dev-libs/librevenge/librevenge-9999.ebuild
@@ -1,47 +1,41 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit flag-o-matic multilib-minimal
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="git://git.code.sf.net/p/libwpd/librevenge"
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/libwpd/librevenge"
inherit git-r3 autotools
else
SRC_URI="https://sf.net/projects/libwpd/files/${PN}/${P}/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
fi
+
DESCRIPTION="Helper library for REVerse ENGineered formats filters"
HOMEPAGE="https://sf.net/p/libwpd/librevenge"
LICENSE="|| ( MPL-2.0 LGPL-2.1 )"
SLOT="0"
IUSE="doc test"
+
RESTRICT="!test? ( test )"
-BDEPEND="
- doc? ( app-doc/doxygen )
-"
-RDEPEND="
- sys-libs/zlib[${MULTILIB_USEDEP}]
-"
+RDEPEND="sys-libs/zlib[${MULTILIB_USEDEP}]"
DEPEND="${RDEPEND}
dev-libs/boost
test? ( dev-util/cppunit[${MULTILIB_USEDEP}] )
"
+BDEPEND="doc? ( app-doc/doxygen )"
src_prepare() {
default
- [[ ${PV} = *9999 ]] && eautoreconf
-
- # bug 651264
- append-cxxflags -std=c++11
+ [[ ${PV} == *9999* ]] && eautoreconf
}
multilib_src_configure() {
local myeconfargs=(
- --disable-static
--disable-werror
$(use_with doc docs)
$(use_enable test tests)