summaryrefslogtreecommitdiff
path: root/dev-libs/libqt5pas
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libqt5pas')
-rw-r--r--dev-libs/libqt5pas/Manifest6
-rw-r--r--dev-libs/libqt5pas/libqt5pas-1.2.15.ebuild40
-rw-r--r--dev-libs/libqt5pas/libqt5pas-1.2.9.ebuild2
3 files changed, 45 insertions, 3 deletions
diff --git a/dev-libs/libqt5pas/Manifest b/dev-libs/libqt5pas/Manifest
index 628cb9f27364..a73380716e60 100644
--- a/dev-libs/libqt5pas/Manifest
+++ b/dev-libs/libqt5pas/Manifest
@@ -1,3 +1,5 @@
-DIST libqt5pas-1.2.9.tar.gz 77272959 BLAKE2B 2d7b2872a7399eb1a3a7d9fb20fed209900603ae433db75ac2c4244edf5e5981314ed3d8e39143ff30764e7ccbf1286edace9c38505df1cd28b44250bdd07224 SHA512 1a2fbc8451f1954df1d0071c586662ebc3cd0e9a7db5d910e0af86a3095252a5796d4c7abcf3861ad723af26974ac416c5bf919cd77ad5f406295ad7cdf47eb1
-EBUILD libqt5pas-1.2.9.ebuild 724 BLAKE2B 3f287e25ec3910348e1144f5ddfcdf6e027af9cb39160e6641ba56384ff18e062d584f7d1fcbfbb613d619573859306f0ffc61267527a490664cbdbf545c02ce SHA512 fa22c626e547b365462a0ccac77dcb74b6eb1d7e358b03fc4e42644bde38825319f662afab76d7fcd0583fc00a4c6f8d5dba969a2354890e51ae3a856af98b66
+DIST lazarus-2.2.4-0.tar.gz 77272959 BLAKE2B 2d7b2872a7399eb1a3a7d9fb20fed209900603ae433db75ac2c4244edf5e5981314ed3d8e39143ff30764e7ccbf1286edace9c38505df1cd28b44250bdd07224 SHA512 1a2fbc8451f1954df1d0071c586662ebc3cd0e9a7db5d910e0af86a3095252a5796d4c7abcf3861ad723af26974ac416c5bf919cd77ad5f406295ad7cdf47eb1
+DIST lazarus-3.0-0.tar.gz 87513233 BLAKE2B 26e8492194541453230832591445b97827e65b61531078cb4bd1c9f549bcd0aa531fef036f701de885e96f9e56476b0dd1c9465e2388ea43080ba418acbd097e SHA512 85cb3548fab017f2fd97f5fb141d59a0d0ec1412a161f98fea726ad5d6ed32ee2eb6ef6573e058d4df7dfcc067256e842acf994b73c9a50ebfb064657db33881
+EBUILD libqt5pas-1.2.15.ebuild 934 BLAKE2B 892271fa4ff50d117707187a484d48452bb6d8fd74afdd9c78fe0e930630b0df65b1cf2fd4336b28865ff1c076a679d12c5a22b2f6fba918f0fe215626bd38e3 SHA512 394f5a9a3becd2abb10dba0165d74b22af46c931b4b05f7403c44699b3cb2a223b1e4300444dd4991b7858f2350c4016de32abdb1d69ad9b543f73e64ae42a9b
+EBUILD libqt5pas-1.2.9.ebuild 709 BLAKE2B 1c41f19742c085a1f6504901212ba2bd9a165825eb75761dcf3a0d1ec0d25c28b25bf39807d0eb9e396ad562c97a3503581b6b547abf37b1a49ef3b4cf3a989b SHA512 7173a8f37b32b04ea6ee8488b1092ba96a4f8706a0180ace51f269b52fac0df6a9071e71f2de24907ddab8864c1ab49d5e3fc84c58f501f9a1d5bcf918263623
MISC metadata.xml 560 BLAKE2B beae1bc1f0e0ab5dbfc903f7dab900d7261543b587b2c5ebe991a6e539bc648289a2743cdf3804fd72a32e1247f3e53a0063ae7c75ad9eaebdfdef675bdc55b4 SHA512 eddf0239dfac852653fd1f2aec51c46818776913555eb4affaedc34ca18583c606ecd34836ed45ce41575000234f93bab95c474eb4d2c49009a913ed177ed03d
diff --git a/dev-libs/libqt5pas/libqt5pas-1.2.15.ebuild b/dev-libs/libqt5pas/libqt5pas-1.2.15.ebuild
new file mode 100644
index 000000000000..b6d25452b1e2
--- /dev/null
+++ b/dev-libs/libqt5pas/libqt5pas-1.2.15.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Get PV from lcl/interfaces/qt6/cbindings/Qt6Pas.pro
+inherit qmake-utils
+
+LAZARUS_PV=3.0
+
+# We want to keep the version here in correspondence with dev-lang/lazarus
+# so dev-lang/lazarus can use the bindings.
+MY_P="lazarus-${LAZARUS_PV}-0"
+
+DESCRIPTION="Free Pascal Qt5 bindings library updated by lazarus IDE"
+HOMEPAGE="https://gitlab.com/freepascal.org/lazarus/lazarus"
+SRC_URI="https://downloads.sourceforge.net/lazarus/${MY_P}.tar.gz"
+S="${WORKDIR}/lazarus/lcl/interfaces/qt5/cbindings"
+
+LICENSE="LGPL-3"
+SLOT="0/${LAZARUS_PV}"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtcore:5
+ dev-qt/qtwidgets:5
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ eqmake5 "QT += x11extras" Qt5Pas.pro
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}
diff --git a/dev-libs/libqt5pas/libqt5pas-1.2.9.ebuild b/dev-libs/libqt5pas/libqt5pas-1.2.9.ebuild
index 090fe8251feb..974c623460a3 100644
--- a/dev-libs/libqt5pas/libqt5pas-1.2.9.ebuild
+++ b/dev-libs/libqt5pas/libqt5pas-1.2.9.ebuild
@@ -9,7 +9,7 @@ MY_P="lazarus-2.2.4-0"
DESCRIPTION="Free Pascal Qt5 bindings library updated by lazarus IDE."
HOMEPAGE="https://gitlab.com/freepascal.org/lazarus/lazarus"
-SRC_URI="https://downloads.sourceforge.net/lazarus/${MY_P}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://downloads.sourceforge.net/lazarus/${MY_P}.tar.gz"
KEYWORDS="~amd64 ~x86"
LICENSE="LGPL-3"