summaryrefslogtreecommitdiff
path: root/dev-libs/libpqxx
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libpqxx')
-rw-r--r--dev-libs/libpqxx/Manifest2
-rw-r--r--dev-libs/libpqxx/libpqxx-6.4.5.ebuild86
2 files changed, 88 insertions, 0 deletions
diff --git a/dev-libs/libpqxx/Manifest b/dev-libs/libpqxx/Manifest
index cf75c7560451..ee3f7f2a364d 100644
--- a/dev-libs/libpqxx/Manifest
+++ b/dev-libs/libpqxx/Manifest
@@ -1,3 +1,5 @@
DIST libpqxx-6.0.0.tar.gz 676528 BLAKE2B a40095ba9851acde1296d93af7e4c4414f334a734b5062874b63a146836105fdde24672707caf623f2073dc1caf87b1053f25c80b10c3fa779fc91a52f9ec7ae SHA512 f237cc03c01a8262eee44a9428206c1cc11b6034dddf540afef145f58eee5c32b880d84832563480d73d834c24311170e2ef6789e100793afbe0b6e393bd4169
+DIST libpqxx-6.4.5.tar.gz 715081 BLAKE2B 4f1356dc5fc9baddd8fdea6095541f4d90657ef0211edec7796ddd3693933b8d37d5bb14e19249a2e4627b85aef11c582b0ffac0226c8e99a70af1d2b0396e5c SHA512 b6f79c4af93876eaf859626c2deae3b23bd4fa1a438390bc01513ccc48b90565d59588f6977e7475bb7b8dbeb8b1c8ef2a4737d8eb4d15682531fbf78590ed5e
EBUILD libpqxx-6.0.0.ebuild 2180 BLAKE2B 7d701220cf445748f4e67104c36bc3d9c8ffbee6633ed578c676416586b440477da4bf48fc31c2291dff2f52e33f5760891177a01098254bdff5f2523da1708b SHA512 9b85c12d7be7acca245f52557cc11063b3064ce8ee09292c31a35402648de7f555134731d675835353ab1ca0639553b4c84adaddb2e92389c7e715eeb51282f0
+EBUILD libpqxx-6.4.5.ebuild 2182 BLAKE2B d432b983ec67d0180f2bad7c35eba72e637298381370944c906e9be96a802564e1237e9e036d038b9adada666f92c2806d1af3950ab4a9ac98de4e865334570d SHA512 f75852441bad878cbb8df6bddcf43b7bd52cd6d102c48f10cefa9e3c67ae88de549cd01a7564f79cd3bf23acd8d013b155d573da7c41d33e529787128fc5a88a
MISC metadata.xml 597 BLAKE2B 2371e4c701506d5e8b4eb0938325a6cd909ad874badbc000a7ea831d2e7ff55cf1b6f4fbb3ae09f9392850319f9cbbbde083492a20cf1209e94139f7b1ceb927 SHA512 c732dc922e3ac9e63a373dbe8b53ef8fb93d87c7cd91a1db1b94e89fe33f3109b818cf0730df36b00f2abf1dc554e1bf261f39db807cf61775b8177db231d37f
diff --git a/dev-libs/libpqxx/libpqxx-6.4.5.ebuild b/dev-libs/libpqxx/libpqxx-6.4.5.ebuild
new file mode 100644
index 000000000000..26fc139ec319
--- /dev/null
+++ b/dev-libs/libpqxx/libpqxx-6.4.5.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-any-r1
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+DESCRIPTION="Standard front-end for writing C++ programs that use PostgreSQL"
+SRC_URI="https://github.com/jtv/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="http://pqxx.org/development/libpqxx/"
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc static-libs"
+
+RDEPEND="dev-db/postgresql:="
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ doc? (
+ app-doc/doxygen
+ app-text/xmlto
+ )
+"
+
+DOCS=( AUTHORS NEWS README{.md,-UPGRADE} )
+
+src_prepare() {
+ default
+
+ sed -e 's/python/python2/' \
+ -i tools/{splitconfig,template2mak.py} \
+ || die "Couldn't fix Python shebangs"
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable doc documentation) \
+ $(use_enable static-libs static)
+}
+
+src_test() {
+ einfo "The tests need a running PostgreSQL server and an existing database."
+ einfo "Test requires PGDATABASE and PGUSER to be set at a minimum. Optionally,"
+ einfo "set PGPORT and PGHOST. Define them at the command line or in:"
+ einfo " ${EROOT%/}/etc/libpqxx_test_env"
+
+ if [[ -z $PGDATABASE || -z $PGUSER ]] ; then
+ if [[ -f ${EROOT%/}/etc/libpqxx_test_env ]] ; then
+ source "${EROOT%/}/etc/libpqxx_test_env"
+ [[ -n $PGDATABASE ]] && export PGDATABASE
+ [[ -n $PGHOST ]] && export PGHOST
+ [[ -n $PGPORT ]] && export PGPORT
+ [[ -n $PGUSER ]] && export PGUSER
+ fi
+ fi
+
+ if [[ -n $PGDATABASE && -n $PGUSER ]] ; then
+ local server_version
+ server_version=$(psql -Aqtc 'SELECT version();' 2> /dev/null)
+ if [[ $? = 0 ]] ; then
+ cd "${S}/test" || die
+ emake check
+ else
+ eerror "Is the server running?"
+ eerror "Verify role and database exist, and are permitted in pg_hba.conf for:"
+ eerror " Role: ${PGUSER}"
+ eerror " Database: ${PGDATABASE}"
+ die "Couldn't connect to server."
+ fi
+ else
+ eerror "PGDATABASE and PGUSER must be set to perform tests."
+ eerror "Skipping tests."
+ fi
+}
+
+src_install () {
+ use doc && HTML_DOCS=( doc/html/. )
+ default
+
+ if ! use static-libs; then
+ find "${D}" -name '*.la' -delete || die
+ fi
+}