summaryrefslogtreecommitdiff
path: root/dev-libs/libofx
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libofx')
-rw-r--r--dev-libs/libofx/Manifest2
-rw-r--r--dev-libs/libofx/libofx-0.10.8.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-libs/libofx/Manifest b/dev-libs/libofx/Manifest
index cff5cf29a9fb..c5484bec1da6 100644
--- a/dev-libs/libofx/Manifest
+++ b/dev-libs/libofx/Manifest
@@ -1,5 +1,7 @@
DIST libofx-0.10.3.tar.gz 225132 BLAKE2B 29dff4cb79a4a535bf255c787e184d103ecdbe975bb4bb223b675bbacaff9f8a228ae0a3dffe7710c2707496ac65c4f48ce993243b8353172c53cb02067d9267 SHA512 6c024628a6a11d9542c669a438223331a033eb820b1a2c3001c60d1ab3fad45ccdec64f9b54dd206fe0058ead8e14e751eb7a3bd88e8f9e1013b0bdd5b6c5242
DIST libofx-0.10.7.tar.gz 1420230 BLAKE2B 03a98fa3dc79519a7e84b5c0df1686ef523c2f2209caa4f4cb3e40f2cbac0172956cab107ef4086f0e13aea2898bdd36e7a56140874cbd8a2a88d5634ef988c2 SHA512 da96d24675cf681d007e3d4f7d83f4fc2ca56d991b4128f4e3a870fd66d70302950b24b1e17e78a9795d19704f1af7cd2102929b3290f27204499f42a24502a2
+DIST libofx-0.10.8.tar.gz 1477698 BLAKE2B d2d232845c251d8cf78b17bb40e8057cb4479a03939b5d2b2750e68a24524c07d2a66a636fdb930521d7872a234b4719190ad1a2a185444a3359bea48e3dc413 SHA512 24373066c4de27416452afc9924874b52e82452ca7681b9bad098c839057fc5e06c1d4b297818e68a25d75166e4898d7cc52c8db648a25c363a7f95934a4f7fa
EBUILD libofx-0.10.3.ebuild 1160 BLAKE2B cdfce6873c28f88c8cdc17b8b640962f494a0ef20e9c02518099ae9498b54eefc103ddaacda063144f7bc28ad7a963fe53503ea8717bc2a02bbbadf3c7f68700 SHA512 da36e60cd6780ab8ce1df578cef553bfec2406e180ad3873098a5cbde535e4a40691ff80daa502f307644c7942e48bd5592758d50eec02a0680e1fa5b6479b7c
EBUILD libofx-0.10.7.ebuild 990 BLAKE2B 8ca537b4aadb23799fafdba8c57aa4c0576219bcf6bb06f41d26ffb15666c2bff3a1ce0383d478c875ea15ba78cddf2cc006a82f85793c79d6ed7f854f6ac903 SHA512 efc48d240828f7a52daa3c434ee5cffa3f68a5e25afdc19a4c0a0c9a4d978795144249282e4272b148d50bba2a9fdf67c9465b395a9393c199bfc789321a8269
+EBUILD libofx-0.10.8.ebuild 990 BLAKE2B 8ca537b4aadb23799fafdba8c57aa4c0576219bcf6bb06f41d26ffb15666c2bff3a1ce0383d478c875ea15ba78cddf2cc006a82f85793c79d6ed7f854f6ac903 SHA512 efc48d240828f7a52daa3c434ee5cffa3f68a5e25afdc19a4c0a0c9a4d978795144249282e4272b148d50bba2a9fdf67c9465b395a9393c199bfc789321a8269
MISC metadata.xml 297 BLAKE2B 819f3298f3f9a816e9630ebce9f8d163b5974cbd76a1e6bf5ad5c499a3e926b887c0396b6f1c8d13e765b3b37cce93188d15b2ff0bef52d98b7f9bb516225bbb SHA512 58f2ece0d8cb8ffb32fc849e42a49cd086c08a0dbd4e03ab78ec51a9224f3ce60c69acaa56712567ee4e1a4d87aabd7830d2a60af1a5669af7a9eb7b4ec4f046
diff --git a/dev-libs/libofx/libofx-0.10.8.ebuild b/dev-libs/libofx/libofx-0.10.8.ebuild
new file mode 100644
index 000000000000..87cfdff2482d
--- /dev/null
+++ b/dev-libs/libofx/libofx-0.10.8.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="Library to support the Open Financial eXchange XML format"
+HOMEPAGE="https://github.com/libofx/libofx"
+SRC_URI="https://github.com/libofx/libofx/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/10"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ dev-util/gengetopt
+ sys-apps/help2man
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? ( app-crypt/gnupg )
+"
+RDEPEND="
+ >app-text/opensp-1.5
+ app-text/openjade
+ >=dev-cpp/libxmlpp-2.40.1:2.6
+ >=net-misc/curl-7.9.7
+ virtual/libiconv
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ # bug #566456
+ append-cxxflags -std=c++14
+
+ econf $(use_enable doc html-docs)
+}
+
+src_compile() {
+ emake all $(usev doc)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -type f -delete || die
+ find "${ED}" -name '*.a' -type f -delete || die
+}