summaryrefslogtreecommitdiff
path: root/dev-libs/libite/libite-2.5.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libite/libite-2.5.2.ebuild')
-rw-r--r--dev-libs/libite/libite-2.5.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-libs/libite/libite-2.5.2.ebuild b/dev-libs/libite/libite-2.5.2.ebuild
new file mode 100644
index 000000000000..1163330dee56
--- /dev/null
+++ b/dev-libs/libite/libite-2.5.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A collection of useful BSD APIs"
+HOMEPAGE="https://github.com/troglobit/libite"
+SRC_URI="https://github.com/troglobit/libite/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+src_configure() {
+ econf --enable-static=no
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+ rm "${ED}"/usr/share/doc/${PF}/LICENSE || die
+}