summaryrefslogtreecommitdiff
path: root/dev-libs/libinput
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libinput')
-rw-r--r--dev-libs/libinput/Manifest2
-rw-r--r--dev-libs/libinput/libinput-1.18.1.ebuild88
2 files changed, 90 insertions, 0 deletions
diff --git a/dev-libs/libinput/Manifest b/dev-libs/libinput/Manifest
index 42ac03e129b0..00bb718bfd5e 100644
--- a/dev-libs/libinput/Manifest
+++ b/dev-libs/libinput/Manifest
@@ -1,3 +1,5 @@
DIST libinput-1.18.0.tar.xz 616732 BLAKE2B 4f12080b5e3496fdb5ccb1375a073860c26037ba47033a7d2d69a2f817b4ab5791aa89be08b193925cddd566a04144c73399cbb196a4cc9d3e07dcfb806d3eff SHA512 9a834f075d7a1f892416bb6b241eb052f749d3aa883c4b39c0f1c9616c115d6b9a541b587508646fddaf0d3fe57af92fe4629b522d1d51196499e7b523e0aa90
+DIST libinput-1.18.1.tar.xz 618524 BLAKE2B 17c5959b6319838dc65f6df7c532d8e048b0295d20178e636dcb3d7a0418f7c107ffc34f280ac0da66011cc80fb8e9f0881b5edd6a4fb64fb674dff6bb5b4526 SHA512 450e38c0f8245aa0165a8047d25aebee646332f0f2ed442bb2d1bd3e723c2082b6d00d6e3bda308981ece8e29b5cddbd56eab900d2b7497705a45fc27b281828
EBUILD libinput-1.18.0.ebuild 2238 BLAKE2B 0298d4a85c802869d83200b71780460ccfd8fc8994632053e19a291caa54d74ef4b893e7694e4c6a2a28f49cb4dc0acb715ddca6725419d2cef9a91f8c19aff8 SHA512 9fda7370585beebc50b3ec3e0541773f255d813cf8e3fe371e830f0234ea955fd0a5873580d5cedcfd10a2413bf732280884bad141febb4aa85f42b30f1b86d7
+EBUILD libinput-1.18.1.ebuild 2244 BLAKE2B 940484eb539ece4d99ffa49c59b26ce1a40b67c69386740ff936bd09aa51f6cd7f16f52cfe94005e771f5049ecf1b8cb11fa4848291ee356cf3ff89729988dc2 SHA512 e908ff161d13981e1e6466e0f10f5829c81aff6d1a3e012973bc1c17ff5d2949f9fe5d5e4f21689317084089381de853b792af8ad2c97d7fa4c273aaf707a812
MISC metadata.xml 448 BLAKE2B c7a735047f8d22e10d1094dc4bbcbd118c025f318280dafd36029484956465c5e459326fb765f04fbdddc03743760a9008c6ac2494ad113387134fb4e79c4c48 SHA512 945c1005dccddac8085fd8b2be635c08d5b4da1f8264d564d10526d11cf814131d1fa5fd7620f35811a90b43686517519f4e9aba9253f5d5d5b69daa25be52bf
diff --git a/dev-libs/libinput/libinput-1.18.1.ebuild b/dev-libs/libinput/libinput-1.18.1.ebuild
new file mode 100644
index 000000000000..7eac9e2a3929
--- /dev/null
+++ b/dev-libs/libinput/libinput-1.18.1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 2014-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit meson python-any-r1 udev
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libinput/ https://gitlab.freedesktop.org/libinput/libinput"
+SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/10"
+[[ "$(ver_cut 3)" -gt 900 ]] || \
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="doc input_devices_wacom test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ $(python_gen_any_dep '
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ dev-python/recommonmark[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/sphinx_rtd_theme-0.2.4[${PYTHON_USEDEP}]
+ ')
+ >=app-doc/doxygen-1.8.3
+ >=media-gfx/graphviz-2.38.0
+ )
+"
+# test? ( dev-util/valgrind )
+RDEPEND="
+ input_devices_wacom? ( >=dev-libs/libwacom-0.20 )
+ >=dev-libs/libevdev-1.3
+ >=sys-libs/mtdev-1.1
+ virtual/libudev:=
+ virtual/udev
+"
+DEPEND="${RDEPEND}
+ test? ( >=dev-libs/check-0.9.10 )"
+
+python_check_deps() {
+ has_version "dev-python/commonmark[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/recommonmark[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/sphinx[${PYTHON_USEDEP}]" && \
+ has_version ">=dev-python/sphinx_rtd_theme-0.2.4[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use doc && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ sed "s@, '-Werror'@@" -i meson.build || die #744250
+}
+
+src_configure() {
+ # gui can be built but will not be installed
+ local emesonargs=(
+ -Ddebug-gui=false
+ $(meson_use doc documentation)
+ $(meson_use input_devices_wacom libwacom)
+ $(meson_use test tests)
+ -Dudev-dir="${EPREFIX}$(get_udevdir)"
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use doc ; then
+ docinto html
+ dodoc -r "${BUILD_DIR}"/Documentation/.
+ fi
+}
+
+pkg_postinst() {
+ pkgname="dev-python/python-libevdev"
+ if [[ -z "${REPLACING_VERSIONS}" ]] && ! has_version "${pkgname}" ; then
+ einfo "${pkgname} must be installed to use the"
+ einfo "libinput measure and libinput replay tools."
+ fi
+
+ udevadm hwdb --update --root="${ROOT}"
+}