summaryrefslogtreecommitdiff
path: root/dev-libs/libgee/libgee-0.20.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libgee/libgee-0.20.5.ebuild')
-rw-r--r--dev-libs/libgee/libgee-0.20.5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-libs/libgee/libgee-0.20.5.ebuild b/dev-libs/libgee/libgee-0.20.5.ebuild
new file mode 100644
index 000000000000..92d774e85027
--- /dev/null
+++ b/dev-libs/libgee/libgee-0.20.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome2
+
+DESCRIPTION="GObject-based interfaces and classes for commonly used data structures"
+HOMEPAGE="https://wiki.gnome.org/Projects/Libgee"
+
+LICENSE="LGPL-2.1+"
+SLOT="0.8/2"
+KEYWORDS="~alpha amd64 arm arm64 ~ia64 ppc ppc64 ~riscv sparc x86 ~x86-linux"
+IUSE="+introspection"
+
+# FIXME: add doc support, requires valadoc
+RDEPEND="
+ >=dev-libs/glib-2.36:2
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ VALAC="$(type -P false)"
+}