summaryrefslogtreecommitdiff
path: root/dev-libs/libgee/libgee-0.20.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libgee/libgee-0.20.1.ebuild')
-rw-r--r--dev-libs/libgee/libgee-0.20.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/libgee/libgee-0.20.1.ebuild b/dev-libs/libgee/libgee-0.20.1.ebuild
new file mode 100644
index 000000000000..107b5a964e0e
--- /dev/null
+++ b/dev-libs/libgee/libgee-0.20.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2
+
+DESCRIPTION="GObject-based interfaces and classes for commonly used data structures"
+HOMEPAGE="https://wiki.gnome.org/Projects/Libgee"
+
+LICENSE="LGPL-2.1+"
+SLOT="0.8/2"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ia64 ~ppc ~ppc64 ~sh sparc x86 ~x86-linux"
+IUSE="+introspection"
+
+# FIXME: add doc support, requires valadoc
+RDEPEND="
+ >=dev-libs/glib-2.36:2
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6:= )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection)
+ VALAC="$(type -P false)"
+}