summaryrefslogtreecommitdiff
path: root/dev-libs/libgcrypt/libgcrypt-1.9.4-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libgcrypt/libgcrypt-1.9.4-r2.ebuild')
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.9.4-r2.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-libs/libgcrypt/libgcrypt-1.9.4-r2.ebuild b/dev-libs/libgcrypt/libgcrypt-1.9.4-r2.ebuild
index c7a2a6fe71fc..d164dfc4b237 100644
--- a/dev-libs/libgcrypt/libgcrypt-1.9.4-r2.ebuild
+++ b/dev-libs/libgcrypt/libgcrypt-1.9.4-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -78,6 +78,13 @@ multilib_src_configure() {
append-flags -fno-tree-loop-vectorize
fi
+ # ideally we want !tc-ld-is-bfd for best future-proofing, but it needs
+ # https://github.com/gentoo/gentoo/pull/28355
+ # mold needs this too but right now tc-ld-is-mold is also not available
+ if tc-ld-is-lld; then
+ append-ldflags -Wl,--undefined-version
+ fi
+
local myeconfargs=(
CC_FOR_BUILD="$(tc-getBUILD_CC)"