summaryrefslogtreecommitdiff
path: root/dev-libs/libdnet/libdnet-1.14-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libdnet/libdnet-1.14-r2.ebuild')
-rw-r--r--dev-libs/libdnet/libdnet-1.14-r2.ebuild84
1 files changed, 0 insertions, 84 deletions
diff --git a/dev-libs/libdnet/libdnet-1.14-r2.ebuild b/dev-libs/libdnet/libdnet-1.14-r2.ebuild
deleted file mode 100644
index 90dbdead4409..000000000000
--- a/dev-libs/libdnet/libdnet-1.14-r2.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-AT_M4DIR="config"
-PYTHON_COMPAT=( python3_{9..10} )
-DISTUTILS_OPTIONAL=1
-inherit autotools distutils-r1
-
-DESCRIPTION="simplified, portable interface to several low-level networking routines"
-HOMEPAGE="https://github.com/ofalk/libdnet"
-SRC_URI="https://github.com/ofalk/${PN}/archive/${P}.tar.gz"
-S="${WORKDIR}/${PN}-${P}"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86"
-IUSE="python test"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-RESTRICT="!test? ( test )"
-
-DEPEND="python? ( ${PYTHON_DEPS} )"
-RDEPEND="${DEPEND}"
-BDEPEND="
- python? (
- dev-python/cython[${PYTHON_USEDEP}]
- )
-"
-
-DOCS=( README.md THANKS )
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.14-ndisc.patch"
- "${FILESDIR}/${PN}-1.14-strlcpy.patch"
-)
-
-src_prepare() {
- default
-
- sed -i \
- -e 's/libcheck.a/libcheck.so/g' \
- -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' \
- configure.ac || die
- sed -i \
- -e 's|-L$libdir ||g' \
- dnet-config.in || die
- sed -i \
- -e '/^SUBDIRS/s|python||g' \
- Makefile.am || die
-
- eautoreconf
-
- if use python; then
- cd python || die
- distutils-r1_src_prepare
- fi
-}
-
-src_configure() {
- econf \
- --disable-static \
- $(use_with python)
-}
-
-src_compile() {
- default
- if use python; then
- cd python || die
- distutils-r1_src_compile
- fi
-}
-
-src_install() {
- default
-
- if use python; then
- cd python || die
- unset DOCS
- distutils-r1_src_install
- fi
-
- find "${ED}" -name '*.la' -delete || die
-}