summaryrefslogtreecommitdiff
path: root/dev-libs/libbase58
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libbase58')
-rw-r--r--dev-libs/libbase58/Manifest1
-rw-r--r--dev-libs/libbase58/libbase58-0.1.4-r1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-libs/libbase58/Manifest b/dev-libs/libbase58/Manifest
index 3e6728fc432d..6dfbc9053545 100644
--- a/dev-libs/libbase58/Manifest
+++ b/dev-libs/libbase58/Manifest
@@ -1,3 +1,4 @@
DIST libbase58-0.1.4.tar.gz 6718 BLAKE2B d192499920a11f95037a46eb02b19ea5cbedefb14541c22a7c72568a69f4ccc0ed9223883fffd3337f12b718f3e39f11888c95a87b1fec481829989bd73dc741 SHA512 9b36fd7308a1a5486d77cb9baeeac49669a2c823998ff0885fee0757d6fca374f796b743e69af087e20a58b95556faf6c48106e034c09879937d96dae5fc7ac9
+EBUILD libbase58-0.1.4-r1.ebuild 1321 BLAKE2B 86feda0a11a1f7964ab39092be08a26afc51c16854e688faf0ed103e1f609663452fab56a2243f1d6636879a52d9f385d5f84ae4f9fb55cb1ce6882bf9b56baf SHA512 5cbb5289d381c926cf4ad21316cc960772f8e6c547267888ea18ff8d836edd0ac2fde746c0899c295e5814f610930cc2dcbc9d1e118ccfec4ea71cfc7dead783
EBUILD libbase58-0.1.4.ebuild 559 BLAKE2B 9194cf1bf7f8f6e5b065f5043efaabfee32e6de8f7d743c45189e9149224b677ef6e310649d1c5b17fd53d715882035514426d5b417ae786d8840b4bd91acab2 SHA512 9d7718bf1cb20eb8208adff9bb65e44ef32ca0804ce403a8868c4ad47b333ca50498d84a758bc0f4c06070a2120ed0896b30106911e9cd8c7d8dcd3e511916f0
MISC metadata.xml 546 BLAKE2B 82f8c4af155cefd55772b9bb93f62ca3ac7bebe9ce51519066ee9439293933490d279a6f0da794d1b39fc7eb1a8bf04ccd911685a11f262549957fcc2bdca476 SHA512 2944ee72c2a86666eba6ad64046c1d607b816ab8f2a0c1f3cc38805ebd4c95f9169afc4438a523298ac0a0038c2d9ea702571fb407fb7bf87d8e8fcb3b2ea052
diff --git a/dev-libs/libbase58/libbase58-0.1.4-r1.ebuild b/dev-libs/libbase58/libbase58-0.1.4-r1.ebuild
new file mode 100644
index 000000000000..375b6956313a
--- /dev/null
+++ b/dev-libs/libbase58/libbase58-0.1.4-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="C implementation of Bitcoin's base58 encoding"
+HOMEPAGE="https://github.com/luke-jr/libbase58"
+LICENSE="MIT"
+
+SRC_URI="https://github.com/luke-jr/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SLOT="0/0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE="test tools"
+RESTRICT="!test? ( test )"
+
+# NOTE: If not testing, we don't need non-native libgcrypt
+RDEPEND="tools? ( dev-libs/libgcrypt )"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/libgcrypt[${MULTILIB_USEDEP}] )
+"
+
+src_prepare() {
+ eapply_user
+ eautoreconf
+
+ # NOTE: Needed because test suite uses srcdir instead of builddir to set PATH and for
+ # multilib support.
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local myeconf=(
+ --disable-static
+ LIBGCRYPT_CONFIG="${EPREFIX}/usr/bin/${CHOST}-libgcrypt-config"
+ )
+ if multilib_is_native_abi && use tools; then
+ myeconf+=( --enable-tool )
+ elif use test; then
+ myeconf+=( --enable-tool --bindir='/TRASH' )
+ else
+ myeconf+=( --disable-tool )
+ fi
+ econf "${myeconf[@]}"
+}
+
+multilib_src_install_all() {
+ if use test; then
+ # It's hard to control this directory with multilib_is_native_abi && use tools, hence -f.
+ rm -rf "${ED}/TRASH" || die
+ fi
+}