summaryrefslogtreecommitdiff
path: root/dev-libs/kpublictransport/kpublictransport-21.08.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/kpublictransport/kpublictransport-21.08.0.ebuild')
-rw-r--r--dev-libs/kpublictransport/kpublictransport-21.08.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/kpublictransport/kpublictransport-21.08.0.ebuild b/dev-libs/kpublictransport/kpublictransport-21.08.0.ebuild
new file mode 100644
index 000000000000..6a375881e3a6
--- /dev/null
+++ b/dev-libs/kpublictransport/kpublictransport-21.08.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="true"
+KDE_GEAR="true"
+KFMIN=5.84.0
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Library for accessing public transport timetables and other information"
+HOMEPAGE="https://invent.kde.org/libraries/kpublictransport
+ https://www.volkerkrause.eu/2019/03/02/kpublictransport-introduction.html"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-libs/protobuf:=
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ test? ( >=dev-qt/qtwidgets-${QTMIN}:5 )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_OsmTools=ON # we have no use for it
+ )
+ ecm_src_configure
+}