summaryrefslogtreecommitdiff
path: root/dev-libs/intel-compute-runtime
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/intel-compute-runtime')
-rw-r--r--dev-libs/intel-compute-runtime/Manifest4
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-24.35.30872.32.ebuild84
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-24.52.32224.5.ebuild84
3 files changed, 172 insertions, 0 deletions
diff --git a/dev-libs/intel-compute-runtime/Manifest b/dev-libs/intel-compute-runtime/Manifest
index 19132245fa77..6ddf8af764e8 100644
--- a/dev-libs/intel-compute-runtime/Manifest
+++ b/dev-libs/intel-compute-runtime/Manifest
@@ -1,3 +1,7 @@
DIST intel-compute-runtime-24.35.30872.25.tar.gz 7375680 BLAKE2B 8aede769b46ecdb2eb49346bc87c1e58fbefa382e80419a301b00197fbdc977f62b001e7670a912a28c736aafc59e60d45a4c4d3e61331d6001307c184d3a4b8 SHA512 4e09f432f1f3a7f8c3b9a7bbd6981f2b26a837fc6f6b4459d21bb51fcce94a3c95726d23fb77be2664c7fbdf4dd270e1ec21af1bc815e718a5df865e8bbdac03
+DIST intel-compute-runtime-24.35.30872.32.tar.gz 7376572 BLAKE2B af924c111d288621ddcb14b9d77ff384c632668705e4858ed27424522b6c96e1e7b54012b202c6ade64da668681f3089d0a35d64ecb97ddec642ace8774b3e47 SHA512 2ac8dbefcc1a86b33afd78b8a1d30a959fb980e47402852514d43503df87ea70ea35f192243b78faedce749b3087f244631080f16ddb099a93ec79698176f6b5
+DIST intel-compute-runtime-24.52.32224.5.tar.gz 7418220 BLAKE2B fa1e165cf20e7c31fff15c19700e3589338edc8255b567131c038fb58086a72243994b08e668ecc43fdbc5668177ab6acb95ff32ac40c7703de90778c876b9db SHA512 548b249aab5a21fd94846a96443fd3f766664ea401ba86803f106b8001d4f4f0224d8581952162c31c12b4aa5bc82fc6b4236929c921c0a93763950a7e221363
EBUILD intel-compute-runtime-24.35.30872.25-r1.ebuild 2047 BLAKE2B b890ad5021719f3dac0e874c5b1a21a6b063634b33401282f23a7e98b2ecff534a18551fd560e1063327039a725095666eca0355dc6ab22913882cf11f87dd2a SHA512 2fcc67b63a59f7547a085a6ab4296d61b3ae84a79852f3b37706aa60f44c2041c9f88dbd7b4f04eee2faed52456e789cab4577f97ee101347d091a3770b60fb5
+EBUILD intel-compute-runtime-24.35.30872.32.ebuild 2068 BLAKE2B 95cf9aad083d6d1d94d8b597271f756ae2a15f1fd44bb6321444f2ffc185c41074506d65f013cdd1b8afc8f6cf2c0d21ea78b75643d6fbb12e2b8f76b2d08169 SHA512 5b154783acf48065e6474e27277308a60572a98397475db38c7b8ab1945a05991faf828c05fa0b74963ce1c89cd618ac6a0bc79fb5cd4c0e3a8181e4009e1ad9
+EBUILD intel-compute-runtime-24.52.32224.5.ebuild 2061 BLAKE2B a493533c2f592bc8616ae862393e7e29de9bcf642b397550ff43d105fe86e4dc11e6259510dc584ad0003880b3f7588428c39ce6e47b8e67ec0938bfa5187929 SHA512 aae9560ad372cce5e76c5d3537cc2ec3faeb4afd290b16968445d9dcf40194535fadac890007d4a8625f739212731904bb220c2fd0d150f87a9cefd8a08b6abb
MISC metadata.xml 1429 BLAKE2B 6c2fde2fda8cd6b9d707c400c5b4d38e3d74dd73617faa9dd80f84100d499182ea959e695a473d32307914e76a26bae531a92677f0e4bedbdf05fc1cbd3095ff SHA512 ac61568ad36df6f6c8470b43f32d048930e4a569ec86d58ff563a86ae748f6bddb8700de487e4967da4998160f1c01517be0817cccc445a821984aff36617b6d
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-24.35.30872.32.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-24.35.30872.32.ebuild
new file mode 100644
index 000000000000..50c31549953b
--- /dev/null
+++ b/dev-libs/intel-compute-runtime/intel-compute-runtime-24.35.30872.32.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_BUILD_TYPE="Release"
+MY_PN="${PN/intel-/}"
+MY_P="${MY_PN}-${PV}"
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Intel Graphics Compute Runtime for oneAPI Level Zero and OpenCL Driver"
+HOMEPAGE="https://github.com/intel/compute-runtime"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0/1.5.30872"
+KEYWORDS="~amd64"
+IUSE="+l0 +vaapi"
+
+RDEPEND="
+ >=dev-util/intel-graphics-compiler-1.0.17791.18
+ >=media-libs/gmmlib-22.5.2:=
+"
+
+DEPEND="
+ ${RDEPEND}
+ dev-libs/intel-metrics-discovery:=
+ >=dev-libs/intel-metrics-library-1.0.182:=
+ dev-libs/libnl:3
+ dev-libs/libxml2:2
+ >=dev-util/intel-graphics-system-controller-0.9.5:=
+ media-libs/mesa
+ >=virtual/opencl-3
+ l0? ( >=dev-libs/level-zero-1.19.2:= )
+ vaapi? (
+ x11-libs/libdrm[video_cards_intel]
+ media-libs/libva
+ )
+"
+
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( "README.md" "FAQ.md" )
+
+src_prepare() {
+ # Remove '-Werror' from default
+ sed -e '/Werror/d' -i CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # Filtered for two reasons:
+ # 1) https://github.com/intel/compute-runtime/issues/528
+ # 2) bug #930199
+ filter-lto
+
+ local mycmakeargs=(
+ -DCCACHE_ALLOWED="OFF"
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
+ -DCMAKE_INSTALL_LIBDIR="$(get_libdir)"
+ -DBUILD_WITH_L0="$(usex l0)"
+ -DDISABLE_LIBVA="$(usex !vaapi)"
+ -DNEO_ALLOW_LEGACY_PLATFORMS_SUPPORT="ON"
+ -DNEO_DISABLE_LTO="ON"
+ -DNEO__METRICS_LIBRARY_INCLUDE_DIR="${ESYSROOT}/usr/include"
+ -DKHRONOS_GL_HEADERS_DIR="${ESYSROOT}/usr/include"
+ -DOCL_ICD_VENDORDIR="${EPREFIX}/etc/OpenCL/vendors"
+ -DSUPPORT_DG1="ON"
+ -Wno-dev
+
+ # See https://github.com/intel/intel-graphics-compiler/issues/204
+ # -DNEO_DISABLE_BUILTINS_COMPILATION="ON"
+
+ # If enabled, tests are automatically run during
+ # the compile phase and we cannot run them because
+ # they require permissions to access the hardware.
+ -DSKIP_UNIT_TESTS="1"
+ )
+
+ cmake_src_configure
+}
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-24.52.32224.5.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-24.52.32224.5.ebuild
new file mode 100644
index 000000000000..d4291a73bbd6
--- /dev/null
+++ b/dev-libs/intel-compute-runtime/intel-compute-runtime-24.52.32224.5.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_BUILD_TYPE="Release"
+MY_PN="${PN/intel-/}"
+MY_P="${MY_PN}-${PV}"
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Intel Graphics Compute Runtime for oneAPI Level Zero and OpenCL Driver"
+HOMEPAGE="https://github.com/intel/compute-runtime"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0/1.6.32224"
+KEYWORDS="~amd64"
+IUSE="+l0 +vaapi"
+
+RDEPEND="
+ >=dev-util/intel-graphics-compiler-2.5.7
+ >=media-libs/gmmlib-22.5.2:=
+"
+
+DEPEND="
+ ${RDEPEND}
+ dev-libs/intel-metrics-discovery:=
+ >=dev-libs/intel-metrics-library-1.0.182:=
+ dev-libs/libnl:3
+ dev-libs/libxml2:2
+ >=dev-util/intel-graphics-system-controller-0.9.5:=
+ media-libs/mesa
+ >=virtual/opencl-3
+ l0? ( >=dev-libs/level-zero-1.19.2:= )
+ vaapi? (
+ x11-libs/libdrm[video_cards_intel]
+ media-libs/libva
+ )
+"
+
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( "README.md" "FAQ.md" )
+
+src_prepare() {
+ # Remove '-Werror' from default
+ sed -e '/Werror/d' -i CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # Filtered for two reasons:
+ # 1) https://github.com/intel/compute-runtime/issues/528
+ # 2) bug #930199
+ filter-lto
+
+ local mycmakeargs=(
+ -DCCACHE_ALLOWED="OFF"
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
+ -DCMAKE_INSTALL_LIBDIR="$(get_libdir)"
+ -DBUILD_WITH_L0="$(usex l0)"
+ -DDISABLE_LIBVA="$(usex !vaapi)"
+ -DNEO_ALLOW_LEGACY_PLATFORMS_SUPPORT="ON"
+ -DNEO_DISABLE_LTO="ON"
+ -DNEO__METRICS_LIBRARY_INCLUDE_DIR="${ESYSROOT}/usr/include"
+ -DKHRONOS_GL_HEADERS_DIR="${ESYSROOT}/usr/include"
+ -DOCL_ICD_VENDORDIR="${EPREFIX}/etc/OpenCL/vendors"
+ -DSUPPORT_DG1="ON"
+ -Wno-dev
+
+ # See https://github.com/intel/intel-graphics-compiler/issues/204
+ # -DNEO_DISABLE_BUILTINS_COMPILATION="ON"
+
+ # If enabled, tests are automatically run during
+ # the compile phase and we cannot run them because
+ # they require permissions to access the hardware.
+ -DSKIP_UNIT_TESTS="1"
+ )
+
+ cmake_src_configure
+}