summaryrefslogtreecommitdiff
path: root/dev-libs/intel-compute-runtime
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/intel-compute-runtime')
-rw-r--r--dev-libs/intel-compute-runtime/Manifest2
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-25.05.32567.12.ebuild84
2 files changed, 86 insertions, 0 deletions
diff --git a/dev-libs/intel-compute-runtime/Manifest b/dev-libs/intel-compute-runtime/Manifest
index 074a2fc9b72e..682748c16b91 100644
--- a/dev-libs/intel-compute-runtime/Manifest
+++ b/dev-libs/intel-compute-runtime/Manifest
@@ -1,5 +1,7 @@
DIST intel-compute-runtime-24.35.30872.32.tar.gz 7376572 BLAKE2B af924c111d288621ddcb14b9d77ff384c632668705e4858ed27424522b6c96e1e7b54012b202c6ade64da668681f3089d0a35d64ecb97ddec642ace8774b3e47 SHA512 2ac8dbefcc1a86b33afd78b8a1d30a959fb980e47402852514d43503df87ea70ea35f192243b78faedce749b3087f244631080f16ddb099a93ec79698176f6b5
DIST intel-compute-runtime-24.52.32224.8.tar.gz 7418670 BLAKE2B 474ba6ed02fd82110730f3b48b64745a821266f14bccb2487ac4ff25b7624c5b3cd18d04f3c9a505606b18c3467f253ab1bf7a75e5c5a6b98843d7a9bc5d13f0 SHA512 a5b9016646776f918fc29379b2f14ba52fb554c7ee9cb9f5ebd3a8921c5247785f3906fe7df7b20907d0067f6fe1e05501b33ef914a37baf3b0002d44acc56e0
+DIST intel-compute-runtime-25.05.32567.12.tar.gz 7519478 BLAKE2B 543f849bb17cf01373700fe35731d1480cc33f923906dc34b6fff668d78b4cbb64e4ebe84a28bbfce7f84caa91f939e4dac2c038f54a66d022a7a9c4ec3afc2e SHA512 04f96ebb87c3f7552a3ba99d71c28ad117d13471cb8fd6886e42aa2b479fda9351a474ec135cb1ec4097929da8042564a7974e36cfc195ad22a14669822cf3e1
EBUILD intel-compute-runtime-24.35.30872.32.ebuild 2067 BLAKE2B 41102162ecb453b5ab09eca4e61464c683a9e21626a1a632dfcb8a28c7f9def988c3474ebb5b594dc6adbde7157191ab21700b066317bd515db137790bd9ac44 SHA512 8ad8578411698e8d6c45f502dd84ebde8ad34002d605f5f2e93764a625bd50a6bd88852d932ab6fab1ac5bc26eb10ef43dd85f8c120ec118bae3e522a80588a5
EBUILD intel-compute-runtime-24.52.32224.8.ebuild 2061 BLAKE2B a493533c2f592bc8616ae862393e7e29de9bcf642b397550ff43d105fe86e4dc11e6259510dc584ad0003880b3f7588428c39ce6e47b8e67ec0938bfa5187929 SHA512 aae9560ad372cce5e76c5d3537cc2ec3faeb4afd290b16968445d9dcf40194535fadac890007d4a8625f739212731904bb220c2fd0d150f87a9cefd8a08b6abb
+EBUILD intel-compute-runtime-25.05.32567.12.ebuild 2061 BLAKE2B 1aff9e5e14a258603a7c9fec54ce803690c999e4b129044f9143e5faaf4bf5e653ba0a6222c223b21a818d163bc2c6aa2e8260baad57f562d145440cb2a5cb1e SHA512 c57c2e10ecec8c69fafcbadeb431a033df6ae7d76805dd49f26120c53007293684b6e2c8e8f44a3ee15f3dcbdbd8d06e1311b5377c39b048cbf265ced4521a98
MISC metadata.xml 1429 BLAKE2B 6c2fde2fda8cd6b9d707c400c5b4d38e3d74dd73617faa9dd80f84100d499182ea959e695a473d32307914e76a26bae531a92677f0e4bedbdf05fc1cbd3095ff SHA512 ac61568ad36df6f6c8470b43f32d048930e4a569ec86d58ff563a86ae748f6bddb8700de487e4967da4998160f1c01517be0817cccc445a821984aff36617b6d
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-25.05.32567.12.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-25.05.32567.12.ebuild
new file mode 100644
index 000000000000..89f84f601d0b
--- /dev/null
+++ b/dev-libs/intel-compute-runtime/intel-compute-runtime-25.05.32567.12.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_BUILD_TYPE="Release"
+MY_PN="${PN/intel-/}"
+MY_P="${MY_PN}-${PV}"
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Intel Graphics Compute Runtime for oneAPI Level Zero and OpenCL Driver"
+HOMEPAGE="https://github.com/intel/compute-runtime"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0/1.6.32224"
+KEYWORDS="~amd64"
+IUSE="+l0 +vaapi"
+
+RDEPEND="
+ >=dev-util/intel-graphics-compiler-2.7.8
+ >=media-libs/gmmlib-22.5.2:=
+"
+
+DEPEND="
+ ${RDEPEND}
+ dev-libs/intel-metrics-discovery:=
+ >=dev-libs/intel-metrics-library-1.0.182:=
+ dev-libs/libnl:3
+ dev-libs/libxml2:2
+ >=dev-util/intel-graphics-system-controller-0.9.5:=
+ media-libs/mesa
+ >=virtual/opencl-3
+ l0? ( >=dev-libs/level-zero-1.20.4:= )
+ vaapi? (
+ x11-libs/libdrm[video_cards_intel]
+ media-libs/libva
+ )
+"
+
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( "README.md" "FAQ.md" )
+
+src_prepare() {
+ # Remove '-Werror' from default
+ sed -e '/Werror/d' -i CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # Filtered for two reasons:
+ # 1) https://github.com/intel/compute-runtime/issues/528
+ # 2) bug #930199
+ filter-lto
+
+ local mycmakeargs=(
+ -DCCACHE_ALLOWED="OFF"
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
+ -DCMAKE_INSTALL_LIBDIR="$(get_libdir)"
+ -DBUILD_WITH_L0="$(usex l0)"
+ -DDISABLE_LIBVA="$(usex !vaapi)"
+ -DNEO_ALLOW_LEGACY_PLATFORMS_SUPPORT="ON"
+ -DNEO_DISABLE_LTO="ON"
+ -DNEO__METRICS_LIBRARY_INCLUDE_DIR="${ESYSROOT}/usr/include"
+ -DKHRONOS_GL_HEADERS_DIR="${ESYSROOT}/usr/include"
+ -DOCL_ICD_VENDORDIR="${EPREFIX}/etc/OpenCL/vendors"
+ -DSUPPORT_DG1="ON"
+ -Wno-dev
+
+ # See https://github.com/intel/intel-graphics-compiler/issues/204
+ # -DNEO_DISABLE_BUILTINS_COMPILATION="ON"
+
+ # If enabled, tests are automatically run during
+ # the compile phase and we cannot run them because
+ # they require permissions to access the hardware.
+ -DSKIP_UNIT_TESTS="1"
+ )
+
+ cmake_src_configure
+}