summaryrefslogtreecommitdiff
path: root/dev-libs/icinga-php-thirdparty/icinga-php-thirdparty-0.10.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/icinga-php-thirdparty/icinga-php-thirdparty-0.10.0-r1.ebuild')
-rw-r--r--dev-libs/icinga-php-thirdparty/icinga-php-thirdparty-0.10.0-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-libs/icinga-php-thirdparty/icinga-php-thirdparty-0.10.0-r1.ebuild b/dev-libs/icinga-php-thirdparty/icinga-php-thirdparty-0.10.0-r1.ebuild
new file mode 100644
index 000000000000..3b297eb00730
--- /dev/null
+++ b/dev-libs/icinga-php-thirdparty/icinga-php-thirdparty-0.10.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Icinga PHP libraries for Icinga Web 2."
+HOMEPAGE="https://github.com/Icinga/icinga-php-library"
+SRC_URI="https://github.com/Icinga/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+DEPEND="dev-lang/php:*"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_install() {
+ insinto "/usr/share/icinga-php/vendor"
+ cd "${S}"
+ doins -r *
+}