summaryrefslogtreecommitdiff
path: root/dev-libs/hyphen
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/hyphen')
-rw-r--r--dev-libs/hyphen/Manifest1
-rw-r--r--dev-libs/hyphen/hyphen-2.8.8-r1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/hyphen/Manifest b/dev-libs/hyphen/Manifest
index d8e2fb3dd5d2..7c992a81a0e1 100644
--- a/dev-libs/hyphen/Manifest
+++ b/dev-libs/hyphen/Manifest
@@ -1,3 +1,4 @@
DIST hyphen-2.8.8.tar.gz 638369 BLAKE2B b20bf9476d573c344eeaa5088da5dad17ef025d37717391965880b60b78908bfa00347b4840267a8bab77bbf0c3d653313e342b892581f1864381c476804c3c1 SHA512 ee514952be56869840b70fb74f60eba14dc4de246733ff8705492367e8cf00c485f8778a9d5a7ba374c988d4ac9fedbe75826dc559e1b62465dbfba21f6ce7de
+EBUILD hyphen-2.8.8-r1.ebuild 768 BLAKE2B cf2d0e251f9313ce19705c36bc593857c1f8233fbf8811071a12b454935dba161101b5243d06bd6522ebfa3f2e4ae569dd499e21d218aab9723fb22016c998b3 SHA512 831cf2fa92f891c0b78841ecf70a8a9c928b6917e7fa82a3a87cf7c9e07ba6c8f5838d792efece11cbc9737b60f625d6cbc84e12e710178ec45430a42d8f761a
EBUILD hyphen-2.8.8.ebuild 733 BLAKE2B bb7a493ab4db6379309368aae7091a02cefdc09f7afe95d3d464ca5ffd8c30b4db1b2eac9fecdf745a1f0cf634da53c7080daa33423eff38d7ad1c7f294caa26 SHA512 e34d5fb56f920b5d2b66e32ef71d366e56b744f32deff5c2685757f1d22320970f4b004793d4d6a1daad67e83d1e36bf476b5752c9d4793ab54640631fff9457
MISC metadata.xml 333 BLAKE2B 989788782df7e4531d2ad8a12b49eb19f8651468467ef9c2894163c9089679622ed1bc597336afb881ca85bf0523e7e8077c8060d46b6237e4ff5dfe16bc1c1a SHA512 1c2849146c40fcf9b1c352d57e9580ea7d9c2fbdc71c5cf601343e3beb9580876b6dc1d42d41abe01163d92c0eb7837fedf85fc3e7408801f0d966ccc8e78ba2
diff --git a/dev-libs/hyphen/hyphen-2.8.8-r1.ebuild b/dev-libs/hyphen/hyphen-2.8.8-r1.ebuild
new file mode 100644
index 000000000000..185c29e311bc
--- /dev/null
+++ b/dev-libs/hyphen/hyphen-2.8.8-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="ALTLinux hyphenation library"
+HOMEPAGE="http://hunspell.github.io/"
+SRC_URI="mirror://sourceforge/hunspell/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1 MPL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RDEPEND="app-text/hunspell"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README{,.nonstandard,.hyphen,.compound} THANKS TODO )
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ docinto pdf
+ dodoc doc/*.pdf
+
+ rm -r "${ED}"/usr/share/hyphen || die
+ rm "${ED}"/usr/lib*/libhyphen.la || die
+}