summaryrefslogtreecommitdiff
path: root/dev-libs/gtx/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/gtx/files')
-rw-r--r--dev-libs/gtx/files/gtx-0.2.2-debug.patch40
-rw-r--r--dev-libs/gtx/files/gtx-0.2.2-docdir.patch16
-rw-r--r--dev-libs/gtx/files/gtx-0.2.2-glib.h.patch15
3 files changed, 71 insertions, 0 deletions
diff --git a/dev-libs/gtx/files/gtx-0.2.2-debug.patch b/dev-libs/gtx/files/gtx-0.2.2-debug.patch
new file mode 100644
index 000000000000..73f6dfaaad2e
--- /dev/null
+++ b/dev-libs/gtx/files/gtx-0.2.2-debug.patch
@@ -0,0 +1,40 @@
+ Makefile.am | 3 +--
+ examples/Makefile.am | 5 ++---
+ src/Makefile.am | 3 +--
+ 3 files changed, 4 insertions(+), 7 deletions(-)
+
+diff --git a/examples/Makefile.am b/examples/Makefile.am
+index e6bba05..67274c1 100644
+--- a/examples/Makefile.am
++++ b/examples/Makefile.am
+@@ -8,8 +8,7 @@ noinst_PROGRAMS = \
+ command
+
+ AM_CFLAGS =\
+- -Wall \
+- -g
++ -Wall
+
+ simple_SOURCES = \
+ simple.c
+@@ -30,4 +29,4 @@ command_SOURCES = \
+
+ command_LDADD = \
+ $(GTX_LIBS) \
+- $(top_builddir)/src/libgtx.la
+\ No newline at end of file
++ $(top_builddir)/src/libgtx.la
+diff --git a/src/Makefile.am b/src/Makefile.am
+index f5f873e..a40d772 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -4,8 +4,7 @@ INCLUDES = \
+ $(GTX_CFLAGS)
+
+ AM_CFLAGS =\
+- -Wall \
+- -g
++ -Wall
+
+ #
+ # Headers to be installed
diff --git a/dev-libs/gtx/files/gtx-0.2.2-docdir.patch b/dev-libs/gtx/files/gtx-0.2.2-docdir.patch
new file mode 100644
index 000000000000..e6f9a196f9f5
--- /dev/null
+++ b/dev-libs/gtx/files/gtx-0.2.2-docdir.patch
@@ -0,0 +1,16 @@
+ Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index aa401dc..4d99442 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -5,7 +5,7 @@ SUBDIRS = \
+ pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = gtx.pc
+
+-gtxdocdir = ${prefix}/doc/gtx
++gtxdocdir = ${docdir}
+
+ gtxdoc_DATA = \
+ README \
diff --git a/dev-libs/gtx/files/gtx-0.2.2-glib.h.patch b/dev-libs/gtx/files/gtx-0.2.2-glib.h.patch
new file mode 100644
index 000000000000..0efab61e9b1f
--- /dev/null
+++ b/dev-libs/gtx/files/gtx-0.2.2-glib.h.patch
@@ -0,0 +1,15 @@
+ src/gtx.h | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/src/gtx.h b/src/gtx.h
+index 57bee60..ab128b0 100644
+--- a/src/gtx.h
++++ b/src/gtx.h
+@@ -24,7 +24,6 @@
+ #define __GTX_H__
+
+ #include <glib.h>
+-#include <glib/gtestutils.h>
+ #include <glib-object.h>
+
+ G_BEGIN_DECLS