summaryrefslogtreecommitdiff
path: root/dev-libs/geoip/geoip-1.6.11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/geoip/geoip-1.6.11.ebuild')
-rw-r--r--dev-libs/geoip/geoip-1.6.11.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/dev-libs/geoip/geoip-1.6.11.ebuild b/dev-libs/geoip/geoip-1.6.11.ebuild
deleted file mode 100644
index 3c6fe0eb74cc..000000000000
--- a/dev-libs/geoip/geoip-1.6.11.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit autotools eutils ltprune
-
-DESCRIPTION="GeoIP Legacy C API"
-HOMEPAGE="https://github.com/maxmind/geoip-api-c"
-SRC_URI="
- https://github.com/maxmind/${PN}-api-c/archive/v${PV}.tar.gz -> ${P}.tar.gz
-"
-
-# GPL-2 for md5.c - part of libGeoIPUpdate, MaxMind for GeoLite Country db
-LICENSE="LGPL-2.1 GPL-2 MaxMind2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="static-libs"
-RESTRICT="test"
-
-DEPEND="
- net-misc/wget
-"
-RDEPEND="
- ${DEPEND}
-"
-
-S="${WORKDIR}/${PN}-api-c-${PV}"
-
-src_prepare() {
- default
-
- eautoreconf
-}
-
-src_configure() {
- econf $(use_enable static-libs static)
- sed -e "s|@PREFIX@|${ROOT}|g" "${FILESDIR}"/geoipupdate-r6.sh > geoipupdate.sh || die
-}
-
-src_install() {
- default
-
- dodoc AUTHORS ChangeLog NEWS.md README*
-
- prune_libtool_files
-
- keepdir /usr/share/GeoIP
-
- dosbin geoipupdate.sh
-}
-
-pkg_postinst() {
- ewarn "WARNING: Databases are no longer installed by this ebuild."
- elog "Don't forget to run 'geoipupdate.sh -f' (or geoipupdate from"
- elog "net-misc/geoipupdate) to populate ${ROOT}/usr/share/GeoIP/"
- elog "with geo-located IP address databases."
-}