summaryrefslogtreecommitdiff
path: root/dev-libs/folks
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/folks')
-rw-r--r--dev-libs/folks/Manifest2
-rw-r--r--dev-libs/folks/folks-0.15.5.ebuild96
2 files changed, 98 insertions, 0 deletions
diff --git a/dev-libs/folks/Manifest b/dev-libs/folks/Manifest
index d03e4d5bf67b..43df6db2a94b 100644
--- a/dev-libs/folks/Manifest
+++ b/dev-libs/folks/Manifest
@@ -1,3 +1,5 @@
DIST folks-0.15.4.tar.xz 493004 BLAKE2B 0e067a39b4e89e8fa41b20f37c774e56fcb1e0c8de23798ced647177b0d9329509ae3c03ff85a00464887deb4ce275c96b2fcf50aa2dd44af02e20b6ee45fe65 SHA512 4dbd0bb82d56a8cb179ab8148ce531817ccd55bd40f8b562eb0d77555b264e5190669b356ff009c81a963fdcacaabc02fe871bf0c3c668a648f2c820da76f25c
+DIST folks-0.15.5.tar.xz 492976 BLAKE2B bb831a637dec44ba0e9bb815c2559e3b7f484734fc297293c392bb2c72dea77c5e8aec3e7c76a096288f84f463041fb0b52a3cb50a83c5d84bed818c6af72a27 SHA512 696d158234cc5b4c504491c6e01dc45ed53c4ac02e3e62e637d229207dde396a82a850d143d8615dc838d99c756edfce145405ea3972c556951d6408fb8487ea
EBUILD folks-0.15.4.ebuild 2348 BLAKE2B 2a6b299326aa74168affff44885f41d61895e91b6c9785a89973abd6c17cd458248cf7e5a956be272bc8181cc68dca44984fd6a2534b402b52356ee85825c7ab SHA512 e0b5a04ee0215820366a79dac1acac2003c17241f0880dbbbc25c6731d065168783812bbd9feea2a1268c462910d367eccdf6671760a6aa7af7298eb78077f73
+EBUILD folks-0.15.5.ebuild 2341 BLAKE2B c4fb6b3a4df8108e1f965e9209b573abf6f0957e82a071c8e202c4d4b221c8d0b212c4d2a57f6c6e492ac70696434e632b97cf19a591d8d75219be90e387d2d5 SHA512 f8c5c669b91e0fda9c740090a245126327864cef1bd024800714f66a4c0ff70e22e54b5a23c8128914b60c8e616e9c25d6d1f9eb6cd2f628eb284a77bfdff840
MISC metadata.xml 396 BLAKE2B f4e55d5af852a227b66080749510b9915ac9c3f7081c88051f06be73465235ccc326db015238366e62c40d6e8027eac233644ad8421eb0b59f881e2ec215a1e2 SHA512 4a6a15a7ecee35f43c7f82d24e82c32ca3811058f5135e473e15bcae21fc3023d61a6c9f638c9d97336baef3fa8126ab31a49eb036545f521dab2bf93c2a0f0a
diff --git a/dev-libs/folks/folks-0.15.5.ebuild b/dev-libs/folks/folks-0.15.5.ebuild
new file mode 100644
index 000000000000..9ee2c090d991
--- /dev/null
+++ b/dev-libs/folks/folks-0.15.5.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+VALA_MIN_API_VERSION="0.48"
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit gnome.org gnome2-utils meson python-any-r1 vala xdg
+
+DESCRIPTION="Library for aggregating people from multiple sources"
+HOMEPAGE="https://wiki.gnome.org/Projects/Folks https://gitlab.gnome.org/GNOME/folks"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/26" # subslot = libfolks soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x86-linux"
+
+IUSE="bluetooth eds +telepathy test utils"
+REQUIRED_USE="bluetooth? ( eds )"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=dev-libs/glib-2.58:2
+ >=dev-libs/libgee-0.10:0.8[introspection]
+ >=dev-libs/gobject-introspection-1.54:=
+ telepathy? (
+ >=net-libs/telepathy-glib-0.19.9
+ dev-libs/dbus-glib
+ )
+ eds? ( >=gnome-extra/evolution-data-server-3.38:= )
+ dev-libs/libxml2:2
+ utils? ( sys-libs/readline:0= )
+"
+# telepathy-mission-control needed at runtime; it is used by the telepathy
+# backend via telepathy-glib's AccountManager binding.
+RDEPEND="${DEPEND}
+ bluetooth? ( >=net-wireless/bluez-5[obex] )
+ telepathy? ( net-im/telepathy-mission-control )
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ $(vala_depend)
+ telepathy? ( net-libs/telepathy-glib[vala] )
+ eds? ( gnome-extra/evolution-data-server[vala] )
+ test? (
+ sys-apps/dbus
+ bluetooth? (
+ $(python_gen_any_dep '
+ dev-python/python-dbusmock[${PYTHON_USEDEP}]
+ ')
+ )
+ )
+"
+
+python_check_deps() {
+ if use test && use bluetooth; then
+ python_has_version "dev-python/python-dbusmock[${PYTHON_USEDEP}]"
+ fi
+}
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use bluetooth bluez_backend)
+ $(meson_use eds eds_backend)
+ $(meson_use eds ofono_backend)
+ $(meson_use telepathy telepathy_backend)
+ -Dzeitgeist=false # last rited package
+ -Dimport_tool=true
+ $(meson_use utils inspect_tool)
+ $(meson_use test tests)
+ -Dinstalled_tests=false
+ -Ddocs=false # Needs find_program sedding to specific version; only dev docs, don't bother
+ )
+ meson_src_configure
+}
+
+src_test() {
+ dbus-run-session meson test -C "${BUILD_DIR}" -t 5
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}