summaryrefslogtreecommitdiff
path: root/dev-libs/ffcall/ffcall-2.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/ffcall/ffcall-2.5.ebuild')
-rw-r--r--dev-libs/ffcall/ffcall-2.5.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/dev-libs/ffcall/ffcall-2.5.ebuild b/dev-libs/ffcall/ffcall-2.5.ebuild
index 7f9d8f6bfae9..2ab0965e1c5c 100644
--- a/dev-libs/ffcall/ffcall-2.5.ebuild
+++ b/dev-libs/ffcall/ffcall-2.5.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit flag-o-matic libtool
+inherit autotools flag-o-matic libtool
MY_PV="libffcall-${PV}"
@@ -19,6 +19,10 @@ LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+PATCHES=(
+ "${FILESDIR}"/ffcall-2.5-add-support-for-clang.patch
+)
+
src_prepare() {
# The build system is a strange mix of autogenerated
# files and manual tweaks on top. Uses $CFLAGS / $LDFLAGS randomly.
@@ -35,6 +39,12 @@ src_prepare() {
default
elibtoolize
+ eautoreconf
+
+ if use kernel_linux ; then
+ QA_CONFIG_IMPL_DECL_SKIP=( PROT_MPROTECT )
+ fi
+
}
src_configure() {