summaryrefslogtreecommitdiff
path: root/dev-libs/crypto++/crypto++-8.6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/crypto++/crypto++-8.6.0.ebuild')
-rw-r--r--dev-libs/crypto++/crypto++-8.6.0.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-libs/crypto++/crypto++-8.6.0.ebuild b/dev-libs/crypto++/crypto++-8.6.0.ebuild
index fe51dc2a3497..0b77d971f0e7 100644
--- a/dev-libs/crypto++/crypto++-8.6.0.ebuild
+++ b/dev-libs/crypto++/crypto++-8.6.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/crypto++.asc
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/crypto++.asc
inherit toolchain-funcs verify-sig
DESCRIPTION="C++ class library of cryptographic schemes"
@@ -13,10 +13,15 @@ SRC_URI+=" verify-sig? ( https://cryptopp.com/cryptopp${PV//.}.zip.sig )"
S="${WORKDIR}"
LICENSE="Boost-1.0"
-# Bumped to 8.5 in 8.5.0 out of caution
+# ABI notes:
+# - Bumped to 8.5 in 8.5.0 out of caution
# subslot is so version (was broken in 8.3.0, check on bumps!)
# Seems to be broken in 8.6 again too
-SLOT="0/8.6"
+#
+# - See https://cryptopp.com/#news, but releases usually say
+# "recompile of programs required". Even if it doesn't,
+# verify with abidiff!
+SLOT="0/${PV}"
KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~loong ppc ppc64 ~riscv sparc x86 ~x64-macos"
IUSE="+asm static-libs"