summaryrefslogtreecommitdiff
path: root/dev-libs/cJSON/cJSON-1.7.15.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/cJSON/cJSON-1.7.15.ebuild')
-rw-r--r--dev-libs/cJSON/cJSON-1.7.15.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/cJSON/cJSON-1.7.15.ebuild b/dev-libs/cJSON/cJSON-1.7.15.ebuild
new file mode 100644
index 000000000000..5e31a6ae07d5
--- /dev/null
+++ b/dev-libs/cJSON/cJSON-1.7.15.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION=" Ultralightweight JSON parser in ANSI C"
+HOMEPAGE="https://github.com/DaveGamble/cJSON"
+SRC_URI="https://github.com/DaveGamble/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ cmake_src_prepare
+
+ sed -i -e '/-Werror/d' CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_CJSON_TEST=$(usex test)
+ )
+
+ cmake_src_configure
+}