summaryrefslogtreecommitdiff
path: root/dev-libs/aws-checksums/aws-checksums-0.1.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/aws-checksums/aws-checksums-0.1.3.ebuild')
-rw-r--r--dev-libs/aws-checksums/aws-checksums-0.1.3.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-libs/aws-checksums/aws-checksums-0.1.3.ebuild b/dev-libs/aws-checksums/aws-checksums-0.1.3.ebuild
new file mode 100644
index 000000000000..cb764eeadcce
--- /dev/null
+++ b/dev-libs/aws-checksums/aws-checksums-0.1.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Cross-Platform HW accelerated CRC32c and CRC32 with software fallbacks"
+HOMEPAGE="https://github.com/awslabs/aws-checksums"
+SRC_URI="https://github.com/awslabs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="test"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake-utils_src_configure
+}