summaryrefslogtreecommitdiff
path: root/dev-libs/aws-c-event-stream/aws-c-event-stream-0.1.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/aws-c-event-stream/aws-c-event-stream-0.1.3.ebuild')
-rw-r--r--dev-libs/aws-c-event-stream/aws-c-event-stream-0.1.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/aws-c-event-stream/aws-c-event-stream-0.1.3.ebuild b/dev-libs/aws-c-event-stream/aws-c-event-stream-0.1.3.ebuild
new file mode 100644
index 000000000000..9da16245ceea
--- /dev/null
+++ b/dev-libs/aws-c-event-stream/aws-c-event-stream-0.1.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="C99 implementation of the vnd.amazon.eventstream content-type"
+HOMEPAGE="https://github.com/awslabs/aws-c-event-stream"
+SRC_URI="https://github.com/awslabs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="test"
+
+DEPEND="dev-libs/aws-c-common"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-add_missing_cmake_install_prefix.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake-utils_src_configure
+}