summaryrefslogtreecommitdiff
path: root/dev-libs/aws-c-common
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/aws-c-common')
-rw-r--r--dev-libs/aws-c-common/Manifest3
-rw-r--r--dev-libs/aws-c-common/aws-c-common-0.4.11.ebuild23
-rw-r--r--dev-libs/aws-c-common/metadata.xml16
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-libs/aws-c-common/Manifest b/dev-libs/aws-c-common/Manifest
new file mode 100644
index 000000000000..839038c1143f
--- /dev/null
+++ b/dev-libs/aws-c-common/Manifest
@@ -0,0 +1,3 @@
+DIST aws-c-common-0.4.11.tar.gz 306933 BLAKE2B 5a2370a3696e4d90b67bc03fbf88f152e1a2d6e4d4a9ff2a9423a2cf18c14a1e3b6d978250c3359f4ebb2cf5e524e416b11604dc09dc45f5c8a5a6f982b344a7 SHA512 1e00f6aa025578978551fc8ca1bc09b448f79ac28bdc969af4312569ffca035d656dc68825da15ad8f4f890bbdb03327c624147dded1ce402e9dab1726290890
+EBUILD aws-c-common-0.4.11.ebuild 484 BLAKE2B 6271c0a5a78d9f1eb6e21a943cea54f747e0fe5dd375f5fdaf6835ec79cfa7f18d7297a0c6dc4fe56cc0b10f6860b619aba4d103a417732ec4c925ec51a71e3e SHA512 083eccf3e46638317d0b2e20e52c8f23e40e0b8606a654f0f3498493b742cd577233d94ac21c026c983fef2a5b1b484839b46ddccb74e438ca8dde569c847304
+MISC metadata.xml 527 BLAKE2B 794ec45e133fb3a39495c56b783b1d7bb5ca7cdd44840a3a305c3137dc5f72cedd7e4acc2e19aae8fc55a43521cc387462337df0ee1a6f0c662fb23b05afd996 SHA512 d859baf8f23805e9f9da7957e88d250f5f34fb24bcfb5c6760c479280d425af641dfc750995b328db197b8b9ee4ea7fee41ceed1a9c06e6b3e4acc7da1cb70e4
diff --git a/dev-libs/aws-c-common/aws-c-common-0.4.11.ebuild b/dev-libs/aws-c-common/aws-c-common-0.4.11.ebuild
new file mode 100644
index 000000000000..e67469eec702
--- /dev/null
+++ b/dev-libs/aws-c-common/aws-c-common-0.4.11.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Core c99 package for AWS SDK for C"
+HOMEPAGE="https://github.com/awslabs/aws-c-common"
+SRC_URI="https://github.com/awslabs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="test"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake-utils_src_configure
+}
diff --git a/dev-libs/aws-c-common/metadata.xml b/dev-libs/aws-c-common/metadata.xml
new file mode 100644
index 000000000000..682226376a67
--- /dev/null
+++ b/dev-libs/aws-c-common/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>yamakuzure@gmx.net</email>
+ <name>Sven Eden</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Core c99 package for AWS SDK for C. Includes cross-platform primitives,
+ configuration, data structures, and error handling.
+ </longdescription>
+</pkgmetadata>