summaryrefslogtreecommitdiff
path: root/dev-libs/aws-c-common/aws-c-common-0.4.11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/aws-c-common/aws-c-common-0.4.11.ebuild')
-rw-r--r--dev-libs/aws-c-common/aws-c-common-0.4.11.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-libs/aws-c-common/aws-c-common-0.4.11.ebuild b/dev-libs/aws-c-common/aws-c-common-0.4.11.ebuild
new file mode 100644
index 000000000000..e67469eec702
--- /dev/null
+++ b/dev-libs/aws-c-common/aws-c-common-0.4.11.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Core c99 package for AWS SDK for C"
+HOMEPAGE="https://github.com/awslabs/aws-c-common"
+SRC_URI="https://github.com/awslabs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="test"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake-utils_src_configure
+}