summaryrefslogtreecommitdiff
path: root/dev-libs/9libs/9libs-1.0-r4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/9libs/9libs-1.0-r4.ebuild')
-rw-r--r--dev-libs/9libs/9libs-1.0-r4.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/dev-libs/9libs/9libs-1.0-r4.ebuild b/dev-libs/9libs/9libs-1.0-r4.ebuild
deleted file mode 100644
index bb14ac5ccbf2..000000000000
--- a/dev-libs/9libs/9libs-1.0-r4.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit autotools toolchain-funcs
-
-DESCRIPTION="A package of Plan 9 compatibility libraries"
-HOMEPAGE="https://www.netlib.org/research/9libs/9libs-1.0.README"
-SRC_URI="https://www.netlib.org/research/9libs/${P}.tar.bz2"
-
-LICENSE="PLAN9"
-SLOT="0"
-KEYWORDS="amd64 ~riscv x86"
-
-DEPEND="
- >=x11-libs/libX11-1.0.0
- >=x11-libs/libXt-1.0.0
-"
-RDEPEND="
- ${DEPEND}
-"
-DOCS=(
- README
-)
-PATCHES=(
- "${FILESDIR}"/${PN}-va_list.patch # Bug 385387
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- tc-export CC
-
- econf \
- --enable-shared \
- --disable-static \
- --includedir=/usr/include/9libs \
- --with-x
-}
-
-src_install() {
- default
-
- # rename some man pages to avoid collisions with dev-libs/libevent
- local f
- for f in add balloc bitblt cachechars event frame graphics rgbpix; do
- mv "${D}"/usr/share/man/man3/${f}.{3,3g} || die
- done
-
- find "${ED}" -name '*.la' -delete || die
-}