summaryrefslogtreecommitdiff
path: root/dev-lang/zig/zig-0.13.0-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/zig/zig-0.13.0-r3.ebuild')
-rw-r--r--dev-lang/zig/zig-0.13.0-r3.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-lang/zig/zig-0.13.0-r3.ebuild b/dev-lang/zig/zig-0.13.0-r3.ebuild
index d893e2e33ea2..474339a4e1a3 100644
--- a/dev-lang/zig/zig-0.13.0-r3.ebuild
+++ b/dev-lang/zig/zig-0.13.0-r3.ebuild
@@ -143,7 +143,8 @@ src_configure() {
# are used only after compiling zig2.
local my_zbs_args=(
--zig-lib-dir "${S}/lib/"
- # Will be a subdir under ZIG_SYS_INSTALL_DEST.
+
+ --prefix "${ZIG_SYS_INSTALL_DEST}/"
--prefix-lib-dir lib/
# These are built separately
@@ -283,7 +284,7 @@ src_compile() {
./stage3/bin/zig env || die "Zig compilation failed"
if use doc; then
- ZIG_EXE="./stage3/bin/zig" zig_src_compile langref --prefix "${S}/docgen/"
+ ZIG_EXE="./stage3/bin/zig" zig_src_compile langref --prefix docgen/
fi
fi
}
@@ -321,9 +322,9 @@ src_test() {
}
src_install() {
- use doc && local HTML_DOCS=( "docgen/doc/langref.html" )
+ use doc && local HTML_DOCS=( "${BUILD_DIR}/docgen/doc/langref.html" )
- ZIG_EXE="./zig2" zig_src_install --prefix "${ZIG_SYS_INSTALL_DEST}"
+ ZIG_EXE="./zig2" zig_src_install
cd "${D}/${ZIG_SYS_INSTALL_DEST}" || die
mv lib/zig/ lib2/ || die