summaryrefslogtreecommitdiff
path: root/dev-lang/yasm/yasm-1.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/yasm/yasm-1.3.0.ebuild')
-rw-r--r--dev-lang/yasm/yasm-1.3.0.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/dev-lang/yasm/yasm-1.3.0.ebuild b/dev-lang/yasm/yasm-1.3.0.ebuild
index e1ef59791ee0..fab7341fef10 100644
--- a/dev-lang/yasm/yasm-1.3.0.ebuild
+++ b/dev-lang/yasm/yasm-1.3.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
PYTHON_COMPAT=( python2_7 )
-inherit python-r1
+inherit python-single-r1
DESCRIPTION="An assembler for x86 and x86_64 instruction sets"
HOMEPAGE="http://yasm.tortall.net/"
@@ -23,7 +23,11 @@ RDEPEND="
DEPEND="
${RDEPEND}
nls? ( sys-devel/gettext )
- python? ( >=dev-python/cython-0.14[${PYTHON_USEDEP}] )"
+ python? ( $(python_gen_cond_dep '>=dev-python/cython-0.14[${PYTHON_USEDEP}]') )"
+
+pkg_setup() {
+ : # Avoid python-single-r1_pkg_setup
+}
src_configure() {
use python && python_setup
@@ -36,5 +40,6 @@ src_configure() {
}
src_test() {
- emake check
+ # https://bugs.gentoo.org/718870
+ emake -j1 check
}