summaryrefslogtreecommitdiff
path: root/dev-lang/scrapscript
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/scrapscript')
-rw-r--r--dev-lang/scrapscript/Manifest4
-rw-r--r--dev-lang/scrapscript/metadata.xml23
-rw-r--r--dev-lang/scrapscript/scrapscript-0.1.1.ebuild33
-rw-r--r--dev-lang/scrapscript/scrapscript-9999.ebuild33
4 files changed, 93 insertions, 0 deletions
diff --git a/dev-lang/scrapscript/Manifest b/dev-lang/scrapscript/Manifest
new file mode 100644
index 000000000000..afec07895a95
--- /dev/null
+++ b/dev-lang/scrapscript/Manifest
@@ -0,0 +1,4 @@
+DIST scrapscript-0.1.1.tar.gz 29042 BLAKE2B 4e462fae8271c045c3f1d1200d9fd1141528d3c364b0d639055f4b401f01cc60dd88314a9f33ea870facff3c424b8e3c8b62c1d6ec2501fd78538ca5d8c906c7 SHA512 dc507fbe3af4fe74f1b774eaabdb594d8589642fe82bbcf13823a58ed917d4c49d2d4e2afe72673e8642480e88e3c09fb7136c4cfbeb0c783316824851c9a1b9
+EBUILD scrapscript-0.1.1.ebuild 651 BLAKE2B 77887291d3e2cccdac269d569758b233509aa5372e8a03fb3a8f6eefa4d361c077f3225e6cedc3e00e6ee6a604ce82157713b1120fd408fc3bac48c64b3acd3d SHA512 8f73b462902cbd2d5864f5958aaf07eb0cb14cdbc2c593485528794e97199211af4de4d23dec175f55bfe9363f60a4359792a0c2e4b88741bc38cf2b0c82d5d1
+EBUILD scrapscript-9999.ebuild 651 BLAKE2B 77887291d3e2cccdac269d569758b233509aa5372e8a03fb3a8f6eefa4d361c077f3225e6cedc3e00e6ee6a604ce82157713b1120fd408fc3bac48c64b3acd3d SHA512 8f73b462902cbd2d5864f5958aaf07eb0cb14cdbc2c593485528794e97199211af4de4d23dec175f55bfe9363f60a4359792a0c2e4b88741bc38cf2b0c82d5d1
+MISC metadata.xml 971 BLAKE2B 9992961001d28b7be0de8b80a44914db8963388ef55d6a93e27889e39017a93eb9fbc3df36a6ac8b506b95ed764e1aff33f1de3ca82e3f83971b85bec61a9ae1 SHA512 2784ab76df28c9600d4bdf93e9a45124a551147842d531ef8dc4251be93433c7870bce8f4f89e80cef02a2f11efa291f0df0ac64da920e920975cdb95faaa1d7
diff --git a/dev-lang/scrapscript/metadata.xml b/dev-lang/scrapscript/metadata.xml
new file mode 100644
index 000000000000..ff83a4e4ceeb
--- /dev/null
+++ b/dev-lang/scrapscript/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ Scrapscript solves the software sharability problem. Modern software
+ breaks at boundaries. APIs diverge, packages crumble, configs ossify,
+ serialization corrupts, git tangles, dependencies break, documentation
+ dies, vulnerabilities surface, etc. To make software safe and sharable,
+ scrapscript combines existing wisdom in new ways: all expressions are
+ content-addressible "scraps", all programs are data, all programs are
+ "platformed".
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/tekknolagi/scrapscript/issues/</bugs-to>
+ <remote-id type="github">tekknolagi/scrapscript</remote-id>
+ <remote-id type="pypi">scrapscript</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-lang/scrapscript/scrapscript-0.1.1.ebuild b/dev-lang/scrapscript/scrapscript-0.1.1.ebuild
new file mode 100644
index 000000000000..2bd71da29ead
--- /dev/null
+++ b/dev-lang/scrapscript/scrapscript-0.1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517="poetry"
+PYTHON_COMPAT=( python3_{11..13} )
+
+inherit distutils-r1 edo
+
+DESCRIPTION="Functional, content-addressable programming language"
+HOMEPAGE="https://scrapscript.org/
+ https://github.com/tekknolagi/scrapscript/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_BRANCH="trunk"
+ EGIT_REPO_URI="https://github.com/tekknolagi/${PN}.git"
+else
+ inherit pypi
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+python_test() {
+ edo "${EPYTHON}" ./scrapscript.py test
+}
diff --git a/dev-lang/scrapscript/scrapscript-9999.ebuild b/dev-lang/scrapscript/scrapscript-9999.ebuild
new file mode 100644
index 000000000000..2bd71da29ead
--- /dev/null
+++ b/dev-lang/scrapscript/scrapscript-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517="poetry"
+PYTHON_COMPAT=( python3_{11..13} )
+
+inherit distutils-r1 edo
+
+DESCRIPTION="Functional, content-addressable programming language"
+HOMEPAGE="https://scrapscript.org/
+ https://github.com/tekknolagi/scrapscript/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_BRANCH="trunk"
+ EGIT_REPO_URI="https://github.com/tekknolagi/${PN}.git"
+else
+ inherit pypi
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+python_test() {
+ edo "${EPYTHON}" ./scrapscript.py test
+}