summaryrefslogtreecommitdiff
path: root/dev-lang/rust
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/rust')
-rw-r--r--dev-lang/rust/Manifest2
-rw-r--r--dev-lang/rust/rust-1.86.0-r1.ebuild (renamed from dev-lang/rust/rust-1.86.0.ebuild)5
2 files changed, 3 insertions, 4 deletions
diff --git a/dev-lang/rust/Manifest b/dev-lang/rust/Manifest
index 4310d2180369..ca03ff99050e 100644
--- a/dev-lang/rust/Manifest
+++ b/dev-lang/rust/Manifest
@@ -68,6 +68,6 @@ EBUILD rust-1.84.1-r1.ebuild 22470 BLAKE2B a025e47e6cd9ef3e697324c91d6bddc171f04
EBUILD rust-1.85.0-r1.ebuild 25603 BLAKE2B ff93bf2c53c5c49517129d9d98060b5e9622f7d9fcd741a7f00e36b64821886a54dc7dbd4dcd3788c50dc870ec87fcff2d0c1d2729764b91a1fbbfc503560262 SHA512 826de51b3999bed6f8932b5411dcf90c37921124337ceb0b6ce9ced5dca301dbd928f5717302e453e350814739a46300c3d5a68446a516d9ba58a3b958567bf7
EBUILD rust-1.85.0.ebuild 25554 BLAKE2B a65966e8268197a3f16ec2b9a3276eff72f9e690116a83c8c5ad5ff9ff7f60d2c8067cab1db6fe6a52ca096849c3fc398df3b1c3b4eda9802af79d66ebf895a9 SHA512 6470370db2420f82e8c5aa8ba6cdd40c369153813916a39ec12224bec7a70f02856a550f45baa064293d7d29e5205d9101ab47cf62acc52ade1e9360c7eaedfa
EBUILD rust-1.85.1.ebuild 25603 BLAKE2B ff93bf2c53c5c49517129d9d98060b5e9622f7d9fcd741a7f00e36b64821886a54dc7dbd4dcd3788c50dc870ec87fcff2d0c1d2729764b91a1fbbfc503560262 SHA512 826de51b3999bed6f8932b5411dcf90c37921124337ceb0b6ce9ced5dca301dbd928f5717302e453e350814739a46300c3d5a68446a516d9ba58a3b958567bf7
-EBUILD rust-1.86.0.ebuild 25611 BLAKE2B 3e5ddd84337af632a64605fcf789576d2986abd598b0f2e38664e419fb95f294db65f15ba75abd18c0fd79c82e208102e01530cdab203b2ef677033738b5b748 SHA512 8c250c470956a144adfdbd0985b6a95c09acd861b9541c52927e9224a6ebc4b876787eedbce98571567c4ab332671ce17f0b0b397668c7c713253a780f403906
+EBUILD rust-1.86.0-r1.ebuild 25604 BLAKE2B 60fb6b621eb2fe6a7ca312d6490e86cfb08c2956aa4bb499edfc996d184120815e5c63618d6273fab02077d68c51901188300a0c75253f823ef0f3515edbe033 SHA512 2b63c27d9a622b40ecb0784c8b40698bed49c08758ce234ae21bf70fbf801a7d82e3dd97714bfb1e11cb8970b5f8bddee525b8bc043e035296f01f106207c26b
EBUILD rust-9999.ebuild 25627 BLAKE2B 186d10a4c875ad0cb5e6754fd0d6918090d5b1b46df37967c19f2eb871a6999696fc4e0cef790634ed4204ae38a43b469bfd45653f1562b9b51a97a2b7db3e10 SHA512 0a4a5c6a83def3a7ccef12105cdfb316e332394b21e8ded0017163da0ee01954917899a862726ec8bd729b569b9678cc6027dd654cf66fe4136721e4d87fdace
MISC metadata.xml 1841 BLAKE2B 48a8167ae44a7f4892b917895298627ac920af6c488180980e65bdeec53b650455fc6d7dddad0a7a8257d473080082377fb6b6df6a834b294b6e6485e6784a1e SHA512 1f5fd792b65ccac89a61233004980d9f7cbaecea5d05f35f9cc2dc9cab4e3ccfcd46828e88770a1b8ba5ca23064b6a75eea72a0b32bcce52bb399b85ac95f755
diff --git a/dev-lang/rust/rust-1.86.0.ebuild b/dev-lang/rust/rust-1.86.0-r1.ebuild
index 084e4f9e03f5..a5a82e00ca6a 100644
--- a/dev-lang/rust/rust-1.86.0.ebuild
+++ b/dev-lang/rust/rust-1.86.0-r1.ebuild
@@ -68,7 +68,7 @@ for _x in "${_ALL_RUST_EXPERIMENTAL_TARGETS[@]}"; do
done
LICENSE="|| ( MIT Apache-2.0 ) BSD BSD-1 BSD-2 BSD-4"
-SLOT="$(ver_cut 1-2)"
+SLOT="${PV%%_*}" # Beta releases get to share the same SLOT as the eventual stable
IUSE="big-endian clippy cpu_flags_x86_sse2 debug dist doc llvm-libunwind lto rustfmt rust-analyzer rust-src +system-llvm test wasm ${ALL_LLVM_TARGETS[*]}"
@@ -719,7 +719,7 @@ src_install() {
# we need realpath on /usr/bin/* symlink return version-appended binary path.
# so /usr/bin/rustc should point to /usr/lib/rust/<ver>/bin/rustc-<ver>
# need to fix eselect-rust to remove this hack.
- local ver_i="${i}-${SLOT}"
+ local ver_i="${i}-${PV%%_*}"
if [[ -f "${ED}/usr/lib/${PN}/${SLOT}/bin/${i}" ]]; then
einfo "Installing ${i} symlink"
ln -v "${ED}/usr/lib/${PN}/${SLOT}/bin/${i}" "${ED}/usr/lib/${PN}/${SLOT}/bin/${ver_i}" || die
@@ -728,7 +728,6 @@ src_install() {
ewarn "please report this"
fi
dosym "../lib/${PN}/${SLOT}/bin/${ver_i}" "/usr/bin/${ver_i}"
- dosym "../lib/${PN}/${SLOT}/bin/${ver_i}" "/usr/bin/${i}-${PV%%_*}"
done
# symlinks to switch components to active rust in eselect