summaryrefslogtreecommitdiff
path: root/dev-lang/rust/rust-1.62.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/rust/rust-1.62.1.ebuild')
-rw-r--r--dev-lang/rust/rust-1.62.1.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-lang/rust/rust-1.62.1.ebuild b/dev-lang/rust/rust-1.62.1.ebuild
index fd5d2a9b6277..b951a931e407 100644
--- a/dev-lang/rust/rust-1.62.1.ebuild
+++ b/dev-lang/rust/rust-1.62.1.ebuild
@@ -310,7 +310,7 @@ src_configure() {
# https://bugs.gentoo.org/732632
if tc-is-clang; then
local clang_slot="$(clang-major-version)"
- if { has_version "sys-devel/clang:${clang_slot}[default-libcxx]" || is-flagq -stdlib=libc++; }; then
+ if { has_version "sys-devel/clang:${clang_slot}[default-libcxx(-)]" || has_version "sys-devel/clang-common:${clang_slot}[default-libcxx(-)]" || is-flagq -stdlib=libc++; }; then
use_libcxx="true"
fi
fi