summaryrefslogtreecommitdiff
path: root/dev-lang/rust/rust-1.56.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/rust/rust-1.56.1.ebuild')
-rw-r--r--dev-lang/rust/rust-1.56.1.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-lang/rust/rust-1.56.1.ebuild b/dev-lang/rust/rust-1.56.1.ebuild
index 690bbad18071..b64af6857612 100644
--- a/dev-lang/rust/rust-1.56.1.ebuild
+++ b/dev-lang/rust/rust-1.56.1.ebuild
@@ -19,7 +19,7 @@ else
SLOT="stable/${ABI_VER}"
MY_P="rustc-${PV}"
SRC="${MY_P}-src.tar.xz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+ KEYWORDS="amd64 ~arm arm64 ppc64 ~riscv x86"
fi
RUST_STAGE0_VERSION="1.$(($(ver_cut 2) - 1)).0"
@@ -41,7 +41,7 @@ LLVM_TARGET_USEDEPS=${ALL_LLVM_TARGETS[@]/%/(-)?}
LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
-IUSE="clippy cpu_flags_x86_sse2 debug doc miri nightly parallel-compiler rls rustfmt system-bootstrap system-llvm test wasm ${ALL_LLVM_TARGETS[*]}"
+IUSE="clippy cpu_flags_x86_sse2 debug doc miri nightly parallel-compiler rls rustfmt rust-src system-bootstrap system-llvm test wasm ${ALL_LLVM_TARGETS[*]}"
# Please keep the LLVM dependency block separate. Since LLVM is slotted,
# we need to *really* make sure we're not pulling more than one slot
@@ -119,6 +119,7 @@ RDEPEND="${DEPEND}
REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )
miri? ( nightly )
parallel-compiler? ( nightly )
+ rls? ( rust-src )
test? ( ${ALL_LLVM_TARGETS[*]} )
wasm? ( llvm_targets_WebAssembly )
x86? ( cpu_flags_x86_sse2 )
@@ -277,11 +278,14 @@ src_configure() {
tools="\"miri\",$tools"
fi
if use rls; then
- tools="\"rls\",\"analysis\",\"src\",$tools"
+ tools="\"rls\",\"analysis\",$tools"
fi
if use rustfmt; then
tools="\"rustfmt\",$tools"
fi
+ if use rust-src; then
+ tools="\"src\",$tools"
+ fi
local rust_stage0_root
if use system-bootstrap; then