summaryrefslogtreecommitdiff
path: root/dev-lang/rust/rust-1.54.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/rust/rust-1.54.0.ebuild')
-rw-r--r--dev-lang/rust/rust-1.54.0.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-lang/rust/rust-1.54.0.ebuild b/dev-lang/rust/rust-1.54.0.ebuild
index 40f81de58ea5..0b2c51587d67 100644
--- a/dev-lang/rust/rust-1.54.0.ebuild
+++ b/dev-lang/rust/rust-1.54.0.ebuild
@@ -140,6 +140,12 @@ QA_SONAME="
usr/lib/${PN}/${PV}/lib/rustlib/.*/lib/lib.*.so
"
+# An rmeta file is custom binary format that contains the metadata for the crate.
+# rmeta files do not support linking, since they do not contain compiled object files.
+# so we can safely silence the warning for this QA check.
+QA_WX_LOAD="usr/lib/${PN}/${PV}/lib/rustlib/.*/lib/.*:lib.rmeta"
+QA_EXECSTACK="${QA_WX_LOAD}"
+
# causes double bootstrap
RESTRICT="test"