summaryrefslogtreecommitdiff
path: root/dev-lang/ruby/ruby-2.7.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/ruby/ruby-2.7.3-r1.ebuild')
-rw-r--r--dev-lang/ruby/ruby-2.7.3-r1.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-lang/ruby/ruby-2.7.3-r1.ebuild b/dev-lang/ruby/ruby-2.7.3-r1.ebuild
index 682230b1d99e..fd9d16014070 100644
--- a/dev-lang/ruby/ruby-2.7.3-r1.ebuild
+++ b/dev-lang/ruby/ruby-2.7.3-r1.ebuild
@@ -18,7 +18,7 @@ SRC_URI="https://cache.ruby-lang.org/pub/ruby/${SLOT}/${MY_P}.tar.xz"
LICENSE="|| ( Ruby-BSD BSD-2 )"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="berkdb debug doc examples gdbm ipv6 jemalloc jit libressl +rdoc rubytests socks5 +ssl static-libs systemtap tk xemacs"
+IUSE="berkdb debug doc examples gdbm ipv6 jemalloc jit +rdoc rubytests socks5 +ssl static-libs systemtap tk xemacs"
RDEPEND="
berkdb? ( sys-libs/db:= )
@@ -26,8 +26,7 @@ RDEPEND="
jemalloc? ( dev-libs/jemalloc )
jit? ( || ( sys-devel/gcc:* sys-devel/clang:* ) )
ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl )
+ dev-libs/openssl:0=
)
socks5? ( >=net-proxy/dante-1.1.13 )
systemtap? ( dev-util/systemtap )
@@ -67,6 +66,10 @@ src_prepare() {
# compiles ruby in a non-standard way, may be dropped
eapply "${FILESDIR}"/2.7/{002,003,010}*.patch
+ # Reset time on patched gem_prelude.rb to avoid the need for a base
+ # ruby during bootstrapping, bug 787137
+ touch -t 202001010000 gem_prelude.rb || die
+
einfo "Unbundling gems..."
cd "$S"
# Remove bundled gems that we will install via PDEPEND, bug