summaryrefslogtreecommitdiff
path: root/dev-lang/python/python-3.9.18.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/python-3.9.18.ebuild')
-rw-r--r--dev-lang/python/python-3.9.18.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-lang/python/python-3.9.18.ebuild b/dev-lang/python/python-3.9.18.ebuild
index ef4bf0a3c3fd..5df9769c3928 100644
--- a/dev-lang/python/python-3.9.18.ebuild
+++ b/dev-lang/python/python-3.9.18.ebuild
@@ -237,9 +237,13 @@ src_configure() {
# pass system CFLAGS & LDFLAGS as _NODIST, otherwise they'll get
# propagated to sysconfig for built extensions
- local -x CFLAGS_NODIST=${CFLAGS_FOR_BUILD}
- local -x LDFLAGS_NODIST=${LDFLAGS_FOR_BUILD}
+ #
+ # -fno-lto to avoid bug #700012 (not like it matters for mini-CBUILD Python anyway)
+ local -x CFLAGS_NODIST="${BUILD_CFLAGS} -fno-lto"
+ local -x LDFLAGS_NODIST=${BUILD_LDFLAGS}
local -x CFLAGS= LDFLAGS=
+ local -x BUILD_CFLAGS="${CFLAGS_NODIST}"
+ local -x BUILD_LDFLAGS=${LDFLAGS_NODIST}
# We need to build our own Python on CBUILD first, and feed it in.
# bug #847910 and bug #864911.