summaryrefslogtreecommitdiff
path: root/dev-lang/python/python-3.8.15_p2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/python-3.8.15_p2.ebuild')
-rw-r--r--dev-lang/python/python-3.8.15_p2.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-lang/python/python-3.8.15_p2.ebuild b/dev-lang/python/python-3.8.15_p2.ebuild
index f03d22173cd6..649ae9032e52 100644
--- a/dev-lang/python/python-3.8.15_p2.ebuild
+++ b/dev-lang/python/python-3.8.15_p2.ebuild
@@ -152,11 +152,6 @@ src_configure() {
# PKG_CONFIG needed for cross.
tc-export CXX PKG_CONFIG
- # Fix implicit declarations on cross and prefix builds. Bug #674070.
- if use ncurses; then
- append-cppflags -I"${ESYSROOT}"/usr/include/ncursesw
- fi
-
local dbmliborder=
if use gdbm; then
dbmliborder+="${dbmliborder:+:}gdbm"
@@ -242,6 +237,11 @@ src_configure() {
local -x LDFLAGS_NODIST=${LDFLAGS}
local -x CFLAGS= LDFLAGS=
+ # Fix implicit declarations on cross and prefix builds. Bug #674070.
+ if use ncurses; then
+ append-cppflags -I"${ESYSROOT}"/usr/include/ncursesw
+ fi
+
econf "${myeconfargs[@]}"
if grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then